Does not react

Sometimes SGP runs nice and without problems. But often it stops with the notification: SGP does not react anymore. Two days ago during daytime with only the camera connected (QHY8L) making darks and flats SGP stopped after 20 minutes or sooner. Once it was still running after 6 hours, but most of time it stops reacting. I have a new Lenovo computer with Windows 10, i& processor and lots of memory. Anybody an idea?

I almost switched to Nebulosity but then one night SGP was working properly. So I was very happy. I made the sequence larger so it would go on making pictures of M51 until sunrise. Alas next morning it turned out it had stopped a few minutes after I went to bed…
I like this program, but other users say it never halts but with me it much more often halts then it is continuing as it should be, please help

Please see this thread for things we need to help track down issues.

Thanks ,

Hello Jared,

Thanks for answering, but is does not bring me further . So I politely ask more:

  1. I cannot find the search functionality under ‘help’ in SGP - Maybe I am to old and to stupid for this, but I can’t help…
  2. I will try again, (I did but maybe the wrong way? ) try to use forum search….
  3. Here in our Dutch language community at none of the SGP users have met the problem ‘Seguence Generator reageert niet meer’ So I seem to be very uncommon, so I felt free to start a topic on this issue.
    Of course I feel very sorry about that, but please, as a paying customer I kindly and politely ask: help me where to find a solution for my problems
    with kind regards, yours sincerely
    P.S. English is not my native language, please sorry for the mistakes.

That post has more recommendations than using the help on the forum. Specifically it asks that you

  • Attach a log
  • Let us know the approximate time the issue occurred
  • Attach the sequence (SGF) file if you happen to have it.

If you could provide those things it would really help us to help you. You can find the SGP log under the “Help” menu in SGP.


Hello Jared,

Thanks for answering,

I will attach a log

the issue ‘SGP does not react’ occurs some nights always, also by day with only the camera connected and making Darks. Ans other nights it does not occur at all with the same equipment.

I will attach a SGF file too,
yours sincerely,

sg_logfile_20160605015254.txt (37.9 KB)

sg_logfile_20160605164817.txt (17.7 KB)

I see a LOT of errors in that log with your camera. How do you have the camera connected? Are you going through a hub? Can you try a different USB cable and connect it directly to your imaging machine?


Hello Jared,

Since a few weeks my new PC - Lenovo is on a table besides the pier. I bought ‘clicktronic’ USB cables with goldplated connectors, which should be extreme reliable, at least the price was extreme ;o). Almost all equipment is connected with my PC directly except the filterwheel.
My Trius SX-35 camera has a hub inside the camera housing, but I use it only for the filterwheel, but I will change to a cable directly to the PC. I will change the cables and tie them up to the Camera’s, focuser and filterwheel. I did use a ‘icron ranger USB 2.0 2304 when my PC is inside but that should be a big lot better quality as an USB hub.
But I must admit the SX-Lodestars x2 guiding camera has a poor USB mini socket and also the Main camera often loses power connection, so I did yesterday improve this.

The problem of the sometimes occurring ‘Ascom’ errors when using the Trius SX-35 and the SX Lodestar I brought to Starlight Xpress but no answer until now.
So I will change this all and keep you informed, last night I went to bed at 03.30 and SGP continued correctly, making subs until 04:31. Because of it was getting light and PHD2 stopped guiding, the last two pictures were to whit.

Thans for your help!

Hello Jared,

I am afraid your program SGP is very unstable. When it halts because of a bad connection - why does it not give a message for bad or lost connection?

I am very sorry because it is very intuitive and has almost all possibilities. Christoph helped me two nights when I was in Botswana, he did not solve the problems but promised me it would be a lot better at home with my Mesu200 mount. Het did help me indeed but later on the problems started.

So give me please an honest advise:
Switch to Nebulosity or Maxim? Or do you have a good solution?
Windows 7 on the new computer and try again?

yours sincerely
Arie Slingerland

Sorry you’re having problems. But we have thousands of users not having issues like this so I think it’s a little unfair to say our application is unstable. Unfortunately most driver communication is very low level and we don’t have a chance to catch those exceptions we catch what we can but some bubble up to the top.

I can’t tell you what to do. It’s your money and decision to make. Sounds like you know that the camera has a poor power connection that has caused problems. I think it’s pretty unfair to blame us when you actually know what the issue is. But if you feel another application is the right choice to make that’s your decision. Imaging is certainly about finding what works well for you.


Hello Jared
I confess you are right. Your program is the most intuitive and it is worth to me three times of the cost of it so €300 if it runs adequate on my machines.
Yes the Trius Rasa has poor power connection. And the Lodestar has a poor USB mini connection. So tonight I will try with an Atik and a Asi ZWO camera as guidercamers

At least the ascom error must dissappear which I get when trying to use the SX camera’s
I leave for three weeks to France and will try many possibilities
Thanks for reaction help and correction
Greetings Arie

Verstuurd vanaf mijn iPhone

Hello Jared
I forgot one qeustions; can the poor power connection cause the Ascom error and or cause SGP to halt?
Gr. Arie

Verstuurd vanaf mijn iPhone

Absolutely. We catch a fair amount of these errors as I saw in your log. But eventually something bad happens and SGP quits. When a device suddenly disappears bad things can happen!


Hello Jared,

While using Nebulosity with my Trius SX-35 camera I found out that this camera is probably the cause of all? problems. It loses connection inside and does not give answer. That is when SGP does not react anymore!! It is just a pity SGP does not tell why…. But Nebulosity did:

So I have to apologize for blaming SGP for the problems I did have. Please forgive me?

So the Trius must go back and I am gonna use the Atik 414 camera. I Hope I will find out how to do plate solve with this camera.

Do I have to change the FOV in the Platesolve settings or does PS pick all dat from the picture taken?

with thanks and greetings

If you do a blind solve it should all be populated from the camera. However you’ll likely need to populate the Height and Width of CCD in the camera settings.

Also SGP did report a similar error about timeout in the logs. However with just a single failure it’s hard to know if it’s the application of the hardware that is the issue.


Thanks a lot!
It is possible to get my profiles back from the former installation?
with regards,

Yes, if you go to Tools>>Options on your old machine you can see where the “Profiles Directory” is located. Just copy the profiles from that directory into the corresponding “Profiles Directory” on the new machine.


Dear Reader,

Since 2 weeks I have the Trius SX35 again on the RASA, but a lot of trouble, SGP NEVER worked nicely. The Trius is repaired it had a bad power supply connector……

On the contrary SGP worked very nice with the QHY8Pro and the Atik 414.

Today I received a message from Starlight Xpress: SGP can not work with 2 Starlight Xpress camera’s so the Trius and the Lodestar can not work at the same time in SGP. Did you know? Do you agree? I think I have to agree and start looking for an other guide camera.

greetings, keep well,
Arie Slingerland

I’m not sure what you think SX told you, but you can use two SX cameras with SGP/PHD. For about 2 years I used a Trius SX694 and Lodestar guider with no problems.

Well SX employe told me SGP could not handle 2 SX cameras and indeed I have allways problems. And when I use a Qhy8pb or the Atik 414 camera with the Lodestar guide canera in SGP it runs almost on its own.
So why does it not work here?
Regards Ary

SGP can only connect one camera at a time. The Lodestar connects through
PHD. But that has nothing to do with SX. You should be able to use both a
main SX camera and SX guide camera (main camera with SGP, guide camera with

Did you properly install the ascom driver for both a SX main camera and SX
guide camera? The installer asks you if you have each of those cameras.

Also, which camera are you choosing in PHD2? There are two you can choose

  1. Starlight Xpress SXV
  2. Starlight Xpress Guider (ASCOM)

I have had better success with Starlight Xpress SXV.