Dome and mount parking issue with slaving function

First, thank you for your great work. The program itself is awesome, and the improvements continue to impress.

My issue is an occasional glitch in the dome parking/shutting.
Quick note, my Dome park position does not align to the scope park position. So, when the mount and dome are properly parked the scope points to roughly 0/360 degrees and the dome slit is at about 42 degrees. The dome must be in this position to close the shutter (home), thus the appropriate box is checked in SGP.

One of the following sometimes happens at end of sequence. This is the state of the equipment in the morning:

1a. Mount is parked properly. Dome is still slaved to mount with shutter open. SGP “attempting to park mount” or something to that effect.
- The slave to telescope box is still checked, when I uncheck it, and move the dome manually to the home position, SGP will then close the shutter and complete the sequence.
1b. Sometimes, the shutter was closed but the dome had been returned to be slaved to the mount. This variant at least shut the dome and parked the scope.
- SGP is complete with sequence and the slave box is still checked

2.Mount is still tracking. Dome is still slaved. SGP says same attempting to park mount.
- the same solution as above. But in this case after manually moving and the shutter close being executed on its own, it also automatically parks the mount.

I have tried all the permutations on the slave settings. I have tried park mount first and not. slaving the telescope manually before sequence and not, any setting which wasn’t for a pause allowing manual intervention for something.

  • I think, SGP sends a go home command to the dome, when dome reports home it sends a close shutter and waits for close to go on. I think that sometimes there is a missing command to un slave the dome before the go home.
  • I think, in my case, the dome is going to its home position, but sometimes before it gets the command to close shutter, it see’s it is supposed to be slaved and goes back to the mount position. Regardless if the mount is in situation 1, parked, or situation 2, still tracking, this is not the home position, and now the dome is stuck. I base this on when these problems happen with me able to see the dome behaving this way, I assume the why.

Again, I see situation 1 and 2 with almost any way I “switch” the SGP settings.

Proposed solution - Have SGP affirmatively un-slave at the start of any parking routine
Do this regardless if the sequence slaved the dome as part of its commands, OR the slave box was already checked before the sequence was run.

I have this problem every 3-4 nights with situation 1b most prevalent. I think my solution works for any user situation as a quick return to a baseline state.

Equipment - TI Dome w/ DDW ASCOMM driver in SGP, AP 1100 w/V2 driver

@CarlN - Did this ever get resolved ?