Dome Setup with SGP

I have an 8’ Explora-Dome and using Diffraction Limited’s MaxDome II rotation and shutter control boards. I also have an Astro-Physics Mach1 with an 11" EdgeHD OTA. I am having some difficulty getting these to work together with SGP. I am currently not using the ASCOM Dome Control or POTH. I am connecting SGP directly to the MaxDome II Ascom drivers and the Telescope to my Astro-Phyisics Mach 1 Drivers.

My current settings are as follows:

MaxDome II Ascom Driver Settings:

SGP Slave Settings:

I have both the Slave to Telescope and At Home to Open/Close unchecked as my starting point. I leave the Park Dome Before Operating Shutter option checked in the MDII driver settings as i need my mount to park before the shutter closes just to minimize the chance of the shutter chain coming in contact with the scope. I tried using the At Home to Open/Close option in SGP, but have never gotten it to work.

My start up sequence is the following steps:

  1. Connect All Equipment (Ctrl-Shift-C)
  2. Move Dome 10 Degrees to the Left
  3. Home the Dome from SGP
  4. Open Shutter by clicking on Open Shutter button in SGP
  5. UnPark Mount
  6. Run Sequence (I have Telescope setting checked to Slave the Dome on start of sequence)

The issues I am having is that this sequence does not run consistently. Sometimes everything works perfectly, It will run my sequence, park the mount, and than Home the Dome and then close the shutter. Other times it seems to get completely lost and will park the mount but leave the dome unparked and the shutter open. Until I can get my sequence to run consistently without issues I unfortunately will not be able to run a night’s imaging sequence unattended which is a bummer as that was the reason for getting the dome in the first place.

The second issue I have is that I cannot seem to get the dome slit to align to the OTA. I have played with the GEM Offset numbers and the North Offset to see if I can get any improvement, but still not able to get the slit to align with the mount consistently. My pier is dead center in the middle of my observatory so no east/west offset should be necessary. Also the RA axis is exactly the same height as the base of my observatory so no offset should be required there either.

I would be very interested to hear if anyone else here has experienced these issues and if there are any suggestions on how to improve my configuration settings or my start up sequence in order to get more consistent results. I would also appreciate any advice on how how to solve my dome slit alignment issue. Should I be connecting SGP directly to the MaxDome II and AP Mach 1 Drivers or should I be using the ASCOM Dome Control or POTH? I am really hoping to get these issues resolved. Otherwise I may have to explore other (much more expensive) options for imaging software to control my observatory. Any help would be greatly appreciated.

Clear Skies and Happy New Year,

Andrew J

I can relate completely to the dome slit alignment issue. Unfortunately I have no answer to it. So, like you, I hope someone else can explain why it is not working in SGP.

I also have an 8’ ED and I have been using MaxIm DL and LesveDomeNet. The dome slaves perfectly using those systems. I just spent a couple of hours using SGP to operate the scope (a Meade LX200) and the observatory with simulators for everything else. The slaving simply does not work in SGP. It misreports the dome azimuth and sets the azimuth incorrectly in LDN.

I disconnect the observatory in SGP, use the LDN UI to reset the home azimuth position by rotating the dome past the home sensor and start over with a different target. Same result – not synced with the scope and misreporting the azimuth. In fact, the misreported azimuth would align with the scope, but that is not where the dome is. The dome is not at the reported azimuth, hence the alignment failure.

The differences between your system and mine may offer clues to someone who knows the SGP software about what is going wrong.

Our mounts are different so the problem is not specific to the mount.

Our dome automation software is different so the problem is not specific to the dome automation software.

When I disconnected in SGP and connected in MaxIm DL and did a GoTo to the same target as I had done with SGP, the scope slewed and the dome rotated to align perfectly with the scope.

It is as though SGP correctly calculates the azimuth to rotate the dome to and then issues commands to rotate it to a different point. It then reports that the dome is now at x degrees, except that it isn’t. Unfortunately, unless this can be resolved, you are correct it means SGP cannot be used.

Obviously others are using SGP. Hopefully, either someone else has encountered the same problem as you and I and they have found how to correct it. Or, the developers can dig deeper and find out why the error is occurring. I am using SGP

The only option I have left to try is turning on tracing in LesveDomeNet. I do not know if MaxDome II has tracing that could be turned on. I do not believe the answer is to fiddle with the slaving parameters unless they are not what the names and tool tips say they are because on their face they seem to be exactly the same as the slaving parameters in MaxIm DL which work perfectly. And, yes, I have switched the Dome “Diameter” between the radius and the diameter values. Neither worked correctly. The SGP descriptive text says units are irrelevant as long as they are consistent. I don’t know if that is true or not. I have only tried inches.

I hope we both can learn the answer because SGP has so much promise and would fit extremely well with the rest of my system.


I’ll be referencing the following image, pulled from DPP Observatory DomeAutomation

If your pier is dead center then you almost certainly need some “north” adjustment. This is lateral value from your dome center to the point where your RA and Dec axis intersect (point A)

Again this is not what you think it is. The GEM Offset is the distance from the RA center of rotation to the middle of your objective (The A to B distance in that image)

You can give Ascom Dome Control a shot but you’ll likely run into the same issues as you’re experiencing with SGP. However it handles things differently and it may get you centered better. I don’t think “other (much more expensive) options for imaging software to control my observatory” is going to fix this for you. This seems to be a setup issue with your dome options.

As for the periodic errors with the dome not closing…we’ll need some logs to look into that. Please see here:

Thank you,

Hello Jared. Happy New Year and Thank You for taking the time during the holidays to respond to my post. It is really appreciated. That said, your post left me a bit confused. If you look at the Observatory Slave Settings in my original post you will notice that the only 2 numbers that are zero are the East Offset and the Vertical Offset. As indicated my mount is dead center in the middle of my observatory so no East/West Offset should be required. Similarly, the center of my RA axis at the same height as the non-rotating base of my observatory so no Vertical Offset should be required either. This just leaves the North Offset and the GEM Offset.

Per my Slave Settings above, you can see that I have this value set to be 5 inches. It is actually closer to 4.5, but SGP rounds up the number when you enter a decimal value. This is the distance between the center of the RA Axis (point A in the picture you posted) and the center of the pier.

Per my Slave Settings above, you can see that I have this value set to be 15 inches. I did not confuse the GEM Offset with the Vertical Offset. The distance from the center of the RA Axis (Point A) to the center of my OTA (Point B) is around 14.5 inches.Again, SGP rounds up decimal values to be 15. I have played with this value by adjusting it up and down by an inch or two in both directions just to see if it made any difference. However, I am still not able to get the slit alignment to work correctly.

I apologize if my original post was not clear, but I thought by showing my Slave Settings it would show that in fact I did understand the differences between the different offsets and to the best of my knowledge I have them set correctly. Additionally I did read and re-read the dome setup procedures in the help file as well as did a detailed searches for other dome related post not only on this forum, but other forums as well. I even called and talk to other people who have domes to see how they setup their domes to confirm what I was entering into the different Offset settings was correct. So I don’t think this was a case of failure to RTFM. However, point taken on the logs. If I experience these intermittent sequence run errors in the future I will try and capture the logs from that time period.

If I am still missing something please let me know, but as far as I can tell I have the correct settings in the Slave Setting in SGP, which still does not explain why I am having a dome slit alignment issue. Any other feedback or advice would be appreciated.

Clear Skies and Happy New Year to everyone.

Andrew J

P.S. I forgot to mention that I am currently using Sequence Generator Pro v2.6.0.25. I tried the new 3.x Beta to see if it would help, but it seemed to have more issues related to being able to complete the sequence. When I get time I will try reinstalling the 3x version and capture the logs for that as well.