Download image interfere with PH2 guiding


I run SGP on a Dell optiplex 780 with Windows 7.
My camera is a brand new ZWO ASI294 on a Newton Quattro 10’"
The mount is the NEQ6 running with EQMOD - connected with bluetooth on COM8
I guide with the Orio Starshoot autoguider with a 50mm guide scope.
The mount is not great, but all defects are predictable and I can achieve good images.
I have the latest ASCOM platform version and ASI294 drivers.
I have a Moonlite ASCOM absolute focuser. (COM6)

My problem is when SGP finish integrating a frame and download it, it wreck havock on the guiding. It throw a huge error off the chart and often ruin the next frame. This happens ONLY IN SGP. When I’m using Sharpcap, I can guide and take picture without problems.
I also tried to disconnect everything in SGP (mount and focuser) to free the ressources, but with no luck, when downloading, boom, guiding hell.
I’m losing 3/4 of my frames because of that.

It is advisable to connect the camera directly to the workstation via USB and not attempt to push all of that data through the same USB hub. If you are not able to do this, be sure to check the “Pause guider during image download” option in the Auto Guider tab of the Control Panel


I did what you said with no luck, because that was not the problem. SGP is not to blame here. I’ll share my story for the one who might be interested.

I found the culprit, it was on the USB for sure, but it wasn’t what I was expecting. My imaging camera is the ASI294 who have an integrated USB hub inside. I connect the focuser and the guider camera on that. The camera itself is connected on an USB2 port directly on the computer. The camera is not operating at full speed because it can run on USB3.
I own an EQ6 Skywatcher mount controlled with EQMOD through an EQBLUETOOTH I did myself using a HC-05 (Bluetooth 2.0). On the computer side, I have no native Bluetooth, so I use an ASUS USB-BT211 dongle. Both have couple of years and the driver is crappy on windows and clog the USB channel. So whenever traffic from downloading a picture add-up, telescope is STOPPING TO TRACK. How is that to screw up auto-guiding ?

I switched to wire connection instead of bluetooth temporarly, and it fixed the problem.

Next improvement :
1 - Add a PCIe USB-3 extension card to have faster camera transfert rate
2 - Change the bluetooth module in my EQBLUETOOTH from the aging HC-05 to something at least bluetooth 4.0
3 - Get a more recent USB bluetooth dongle with hopefully better coded driver. I would install a PCIe Bluetooth card but I have no more PCIe slot free (I have only one, and USB-3 is more important)

Cleat skies,