Downloading.... ASI1600 and SGP

It’s been an issue off and on, but now it’s mostly on.
It seems to happen fairly often during plate solving or anytime I change exposures. So if I am doing frame and focus at 1 second then PS for 10 seconds, then go to image for 90, 120, 300 seconds, at some point between all of that the image will just say downloading and nothing will ever happen. It just times out.

Just recently it only downloads. I haven’t been able to capture an image in several days.
I am using SGP
I am using ASI ASCOM

Any insight or ideas?

Pssssssst: Post some logs, it makes it easier for the developers.


Good idea, thanks. I am a bit of a newbie.
I can’t find where it’s saving them, but I can find the current log

Admin - Pasted logs removed for readability

[11/20/2016 5:07:05 PM] [DEBUG] [Camera Thread] SGM_FRAME_AND_FOCUS message received…
[11/20/2016 5:07:05 PM] [DEBUG] [Camera Thread] ASCOM camera: frame and focus…
[11/20/2016 5:07:05 PM] [DEBUG] [Camera Thread] SetAscomNormalSpeed…
[11/20/2016 5:07:05 PM] [DEBUG] [Camera Thread] Cannot set readout speed, not supported by camera…
[11/20/2016 5:16:19 PM] [DEBUG] [Camera Thread] ASCOM Camera: abort message received in download…
[11/20/2016 5:16:19 PM] [DEBUG] [Camera Thread] ASCOM Camera: Attempting to abort exposure…
[11/20/2016 5:16:19 PM] [DEBUG] [Camera Thread] ASCOM Camera: Exposure aborted…
[11/20/2016 5:16:19 PM] [DEBUG] [Camera Thread] ASCOM Camera: Blocking until image is aborted…
[11/20/2016 5:16:19 PM] [DEBUG] [Camera Thread] ASCOM Camera: Image is aborted…
[11/20/2016 5:16:20 PM] [DEBUG] [Camera Thread] SGM_FRAME_AND_FOCUS complete…

Your problem may be different than mine, but this happened to me when I tried to run my ASI1600 on a shared USB port. It completely went away when I connect the camera through a dedicated USB 3 port on my laptop.


I keep the camera on it’s own port. What is weird is nothing changed. No new cables, no new hubs, no updates. It just went from working most of the time to not working at all.

I have the same problem at times. I have no idea about this thought but is it due to the size of the image coming off the ASI 1600 chip? It seems that even when the download goes correctly it takes an extremely long time for that to happen. I have my ASI camera hooked up to a USB 3 port on my computer and it is very slow so I think it must be something with the SGP interface.


Mine doesn’t take too long when it works. I am just bummed because of course it’s clear now and I can’t image because I can’t get SGP to download the image from the camera.


Hi there, we don’t have any way of telling why this is happening without seeing and correlating the actual ASCOM camera logs.

Also, here are more specific instructions on how to make the process of asking for help smoother:

Ok. Sorry for breaking so many rules.
I connected the camera and tried again with no luck. I looked and I don’t see any ASCOM files for today. I didn’t document the times I had issues so the other ones from previous sessions are hours and hours long. So I guess I’ll set everything up and hopefully all the other ASCOM gear will generate a file. The camera alone doesn’t seem to do it.
I am not sure why, I am not too tech savvy with all of this stuff.


Have you tried a different cable and reducing the camera’s USB speed to 40? And are you using a USB 2 or 3 port? I’m sure you’ve read all the same threads I have over on CN, but I don’t hear of a lot of people having download issues any longer and I’ve never really heard a case for these problems being related to SGP.

Wait, one more thing. Are you running SC at the same time? You do use SC for PA, no? That was also a problem for me - the two drivers do not seem to be compatible and I would get download hangs in SGP. I have to run SC alone, PA, then properly exit out of SC otherwise SGP will crash.

Larry (hawkdl2 on CN :wink: )

Hey Larry, I tried reducing the speed and it didn’t work.
But then I was trying to get ASCOM to made a log and tried reducing it again, but this time it worked. I still have to cancel plate solves a lot because it just downloads forever. Even after 10+ minutes it’s still downloading and nothing ever happens. But usually one or two more tries and it’ll work. I played with USB speeds from 40-80. It’s just an on going issue.
I have tried different cables and it doesn’t seem to help. I am using USB 2. My MBP doesn’t have USB 3.

I wasn’t using SC, I gave up on trying to get that to work for PA. Right now I am borrowing my Dad’s CGE Pro and his polemaster while they finish cleaning out the flood damage at his house. Good timing since my mount went to crap again and is with Ed for a hypertune.


I had similar issues when I first got my ASI1600MM-C. I now have my USB speed set to 45 and I have the ASI1600 on its own USB port and also on its own controller on my laptop. My laptop (HP EliteBook) seems to have 2 root USB controllers - one that controls the ports on the left side and one the controls the ports on the right side of the laptop. I do not connect anything other than the ASI1600 to the left side of my laptop. Everything else (guider, mount, etc) connects to the ports on the right. I can’t explain why this works but I have not had the download hanging issues since.

Hope this helps,

1 Like

I would recommend getting the latest ASCOM and system drivers for the ZWO and also moving to the SGP Beta. We’ve made quite a few changes that make things better for the ZWO ASI in the last few betas.

I also have a ASI1600MC-Cool and have been doing a lot of testing and imaging with it. I haven’t had a single problem in sometime. I’m also connected via USB2 (3 also works) with the USB limit set to 45, if I recall correctly.


Thanks David and Jared. Sam at ZWO said to revert to the .13 driver (vs the .16)
I’ll try the beta SGP. I have wanted to try the dither every X frame.


You probably have seen my posts on this topic in other forums. It had been an extremely frustrating problem for me - nothing seemed to help. I have now taken these steps which have eliminated the problem for me over the past 30+ hours of imaging:

  1. I swapped out ZWO’s USB3 cable for a new one.
  2. I always run the camera at USB3 with a USB setting of 40.
  3. I always plug the camera directly into the back USB3 port of my PC, not the front USB3 ports.

I need to do all 3 above or I have the downloading problem.

My take on this is that the camera USB3 driver is not very stable. It troubles me that I have a new, state of the art PC and still I cannot run the camera with the front side USB3 ports for some reason. My guess is that your problems are USB3 port related.

Good luck - I know how frustrating it is.


Thanks Garyl. ZWO just pushed out a new driver, but I am waiting to make sure I have everything calibrated right as I heard new drivers mean you need to do new calibration frames.
Things seem to be working better with the new SGP beta and lowering the USB speed.


Hopefully the new driver will fix the problem, but your right, I’ve had to make new calibration frames every time I update the driver. I think it’s because they continually try to reduce glow - it’s certainly a lot less now than when I first got the camera. Good luck. If this doesn’t fix your problem, and you have tried a new USB cable, it may simple be that your USB ports are not actually different ports as far as the computer is concerned and the only solution may be to try a new laptop with better USB port management.

Jon Rista posted some information a few months ago on how to tell if your ports are actually on separate controllers using Device Manager (or the MAC equivalent, I presume).