Downloading image hangs up... sometimes


SGPro is working flawlessly for me, except sometimes it just hangs up when image downloading. It just keeps waiting forever, and I only notice thanks to the GNS.

Tried the latest beta, and some older version, same problem.

Could it be related to the camera driver? It is a QHY 22. My computer is running WinXP.

Using the same camera, same everything actually with MaximDL never had a problem.



Hi jaime
I have the exact same problem with my atik 460ex when using SGP.
MaximDL never hangs.
I get less problems (not zero though) if I run usb directly to computer, not via USB hub.
But since maxim works with hub as I see it problem is with camera driver probably.
Maxim has less demands on camera driver since it is single threaded. SGP is multiple threaded
SGP could use some better handling of lost Connections, hope they implement it some day


Bit of a “me too” with an Atik One 6 … on cancelling the sequence the following morning, magically it downloaded two images … sadly after 5 hours of being “hung” DL’ing the first. :confused:

Thankfully the UK has many clear nights so nothing lost :wink:

It will be worth while emailing Atik support.

My guess, based on several reports and writing the ASCOM driver for Atik, is that there could be some threading problem and that checking the CCD temperature during an image download could cause a problem. Unfortunately I don’t see it with my system.

SGP pulls no punches and does a lot of multi-tasking so it’s particularly prone to this. In particular the CCD temperature control/monitoring seems to be running in a different thread to the image acquisition and download. The problem seems to be associated with reading CCD temperature during an image download.

The released ASCOM driver locks so there should only be one command active at a time but maybe that’s not enough. I’ve tried adding more locks so that CCD temperature reads can’t be done at any point in the download process. I hope this will help but there are limits to what I can do, especially as I don’t seem to see the same issue myself.

I’ve contacted Atik about this but I think they may not be back until next week. I think it will be better to go through them for this, they may have other ideas about what’s happening.

The other thing that could help is if SGP were to be less enthusiastic about using multiple threads. I realise this should not be necessary but it could help.

Please bear in mind that I’m not speaking for Atik. I developed the ASCOM driver for them some years ago and that’s all.

I guess the same is happening with QHY’s driver. I’ll talk to them to see if they can make it thread safe.

Best regards!