ENABLE Smart Focus with new Quadratic Focus

Many of us, myself included, have previously disabled smart focus because the old routine would often, with smart focus enabled, not recognize a bogus focus run and continue marching in the wrong direction getting progressively more out of focus. This was particularly recommended for scopes with central obstructions.

With the new Quadratic focus routine and associated improvements with SGP handling the entire focusing sequence, it is important to ENABLE Smart Focus. Doing so will improve your odds of returning to good focus rather dramatically.

My run last night with the TV127, illustrates this perfectly. To start the evening I purposely did not adjust my focus position from the prior night to start in good focus, just to see how the new routine would handle this. This scope is a refractor but my AG12, a Newtonian central obstruction scope gets very comparable curves. I still had smart focus DISABLED since I have always run that way.

After five data points, here is what the focus curve looked like:
Although the graph does not show the Quality, it was 100%, as good as it gets. @Ken it would be a good idea to show the Quality on these intermediate graphs. You are using that internally to decide whether or not the results at this point in time, ie. after 5 data points, is good enough to rely on to shift focus and start over.
It this case, the quality was perfect and the focus was getting progressively worse, so obviously the routine should quit, move the focuser to the lowest data point, and start over. If it had done this, I would have had perfect focus on the next focus series.

However, I had Smart Focus disabled, so it did not move the focuser. Instead it just continued taking more images and ended up with this:

Since this curve fails the Quality test, it does a rerun from the SAME position, and of course gets the same results: (no surprise here)

If I had ENABLED Smart Focus, I would have gotten the following result on the first rerun. I terminated the focus run, then set focuser position to 21590, and got this result:

Moral of this story: ENABLE Smart Focus

1 Like

I am afraid I will have to retract this recommendation for the immediate future. My runs from last night brought to light some, unfortunately, very common scenarios where having Smart Focus turned on can cause focus to get badly confused, and maybe never recover.

Interfacing the new Quadratic fit routine with the higher level control of what the program does with the output from Quadratic is very complex and there are many options of how to deal with different situations.
I have suggested some programming changes to Ken and Jarod that should fix these interface issues, but it will take a while for them to get the changes installed and tested.

It the mean time, I suggest to turn off Smart Focus, even for central obstruction scopes. In theory this feature can work really well, but the new routines need some tweaking first.