Eq6-r and SGP

Is there a way to use the eq6r without using Eqmod? I don’t know why but for years everything worked and now it goes sometimes yes and sometimes no… I’m going crazy…

I installed version 3.2 and with that everything works. Of course it’s sad to pay for updates and then have to use the old software…sigh…

I don’t think anything has changed with SGP in recent versions to preclude Eqmod based telescopes from working with it. If you can give us more information or post a log we can probably help figure out why 4.x isn’t working.

A guess would be maybe the version of the drivers that you have installed is only 32 bit and you either need to install a 64bit driver or use the 32bit version of SGP.


So could I try to install the 32 bit version?

Probably a good option. What error did you get when you attempted the 64bit version of SGP?


I use an EQ6-R Pro with Green Swamp Server with good success.

With version 4 64bit the mount works sometimes yes and sometimes not, for example I run the plate solve and it does.
Then I start the sequence, it does the plate solve, it finds a correction to make but the mount doesn’t do anything, then it tries and tries again but the mount doesn’t do anything.
At first I thought it was the computer’s fault and I reset windows but nothing.
Then I thought I had a problem with the mount and I replaced the mount’s motherboard but nothing.
Eventually by putting version 3 of SGP everything started working again.
But I hadn’t had any problems for years and I’d been using the 64-bit version 4 ever since it came out.
Only a few months ago it started giving problems.

I’ll try to look, thanks

1 Like

Please could you show me your setup with Green Sweamp Server? Do you also use automatic meridian inversion?
Thank you

Sure, what part do you need to see?

One critical point is that in PHD2 you need to check the option to invert commands after the meridian flip.

It would help me to see how you configured the GSS because this is the first time I’ve used it.
Thank you!

It’s raining and my Mount is sitting outside (protected) while my controlling computer is inside and I can’t show you the parameters without a connection between the two

I would recommend following James Lamb’s setup video here:

I’ll look, thanks!