EQMOD Connection - 'Unknown' RA and DEC

Hello. I recently upgraded to SGP on Windows 7, connected to an Orion Atlas mount through the EQASCOM driver. SGP is able to successfully connect to the EQMOD ASCOM EQ5/6 driver, and do things like Park, Unpark, Nudge. But it does not show the Current RA or Current DEC values in the Telescope control, or in Control Panel. Both RA and DEC are ‘Unknown’. Attached is a screen shot of SGP and the EQMOD window.

I’ve tried things like reboot, reconnect, power off/on.

Any ideas?

Which version of .Net do you have installed ?

I have .Net 4.8.03761 installed.

Have you also updated all the Ascom\EQMod drivers as well ?

Hi. Yes, I updated the EQMOD drivers to the latest - 2.00q. As I said, controlling of the mount works, but SGP does not show the current position (RA/DEC). I tried a different telescope driver - Telescope Simulator for .NET and I see the same behavior. RA/DEC are both ‘Unknown’. Other programs (PHD, Starry Night) all show correct RA/DEC.

As a test, I uninstalled SGP and installed That older version worked fine.

So, I uninstalled that; reinstalled and moved my config directory so SGP would not load any existing config. Same issue - RA/DEC ‘Unknown’ even when starting with a fresh install and no equipment config.

The last version that works for me is With this version, the RA/DEC briefly flash ‘Unknown’, but then quickly display the correct coordinates.

Something changed with the version.

I would hate to have to stay on an old version, though.

We’ll need SGP logs to take a look.

Thank you,