Equipment Profiles beta 11 problems

I was running beta 11 last night and overall it ran well but I did note some problems while working with equipment profiles.

  1. I used “save sequence as profile” to save a profile (FSQ Pulseguide)

  2. Later I tried to do the same thing (twice) by saving the same profile again to change a couple settings but that profile, previously saved, did not show up as an option so I saved it again (twice) by typing it in.

  3. The next time did this, instead of no entries, there were three:

  1. So I went to profile manager and deleted one of these (FSQ Pulseguide) entries.
  2. When I next tried to load one of the two remaining entries from profile manager, I got the following file missing msg.

Further than that, although only the above entires show up in the profile manager, here is what the directory that holds these looks like:

At first I thought this might be another example of the file name with spaces issue. I saved a sequence as profile w/o spaces and at first it showed up properly in all three places:

But the next time I tried to load it or save it, it was once again gone from both the profile manager and the save sequence as profile (but still there in the directory).

IMPORTANT UPDATE: These problems all happened with a sequence running. Once my darks were done I shut down the PC and equipment and then thought maybe I would try this stuff again with no sequence running so I did that.

Everything seemed to operate totally as it should when nothing was connected and no sequence was running. I am pretty sure I was able to do these things during a sequence with 2.3 but don’t recall for sure.

I am not sure if logs will help with this but I can post them on request if they will help.

So the bottom line is that this is an issue but if it works with no sequence running it is not as much of an issue (one just has to remember not to try doing profiles with a sequence running).

Thank you for the very detailed write up. It is, as always, extremely helpful. Quick questions… the sequence that was running… was that created with the profile you were modifying? How did you load / create the sequence that was running? Lastly (and probably not an issue for this bug)… are you in the US?

Not quite. The way I did it was to bring in a sequence from my V 2.3 machine, load that and then modify that sequence (in control panel) for the things that were different (such as using the new TheSky ASCOM driver, and adjusting some of the new parameters such as in focus). Then I saved that as a new profile as well as saving the modified sequence. I don’t think I closed and re-opened the sequence before running it (don’t remember for sure). That was for the FSQ that got “duplicated”. I then switched scopes and did the same thing with a TOA profile from the other (2.3) machine. At least I think that was the way I did it, when one starts seeing weird things one often flounders about a bit trying different things so there may have been other things I did but those were the main things.

Could the issue be caused by the fact that the original sequence that the profile was made from was created in 2.3? If you think so, I could try creating a fresh profile and/or sequence from scratch in 2.4 next time. OTOH, these were the same sequences/profiles that seemed to be OK afterwards when nothing was running so maybe not.

Yes, Oregon.

Ok thanks. The sequence running / not running does not appear to be relevant. That said, I did find a pretty nasty bug from mis-management of some of the profile memory. It could cause the issue you are seeing if the right series of steps is taken. I have resolved this issue and it will be out in the next release.

OK, thanks. That is good to know. Fortunately it is more of a an equipment management issue than an operational one.

UPDATE: I am imaging again tonite and so far have not seen these issues. No changes were made to the system or SW. All of the files are showing up in both save sequence as profile and in profile manager. Weird.