"external control of telescope" listening on wrong network adapter

Hi. I have a Win8 PC connected to the local network (& hence internet) over WiFi but with the telescope connected to ethernet on the PC and when I try to enable “external control of telescope” it advertises an address on the ethernet subnet not the WiFi subnet, so nothing on WiFi can connect to it.

I’ve tried re-ordering adapters so WiFi is first in the adapter list, no luck. Also tried tricking SGP by temporarily disabling ethernet and enabling external control whence it advertises a connectable WiFi subnet address, but as soon as I reenable the ethernet adapter, the address flips back to the unconnectable ethernet subnet.

Is there any way to force the adapter that SGP uses to open it’s scope-control listening port?


Yea, I dunno how to fix that :yum:. I’m sure Jared or Ken will be around shortly.

Actually, it looks like I may be able to bridge those two networks. I’ll ping back again if that doesn’t work.


1 Like

Ken or Jared,

Is there a way to change this so instead of SGP randomly picking one of your IP addresses you are allowed to select a interface or bind to instead? Right now SGP binds to a unused interface and I’m not sure how to change that.