Failed to meridian flip, aborting sequence

Hello, last night I photoed M101 with SGPro+PHD, started to run the sequence and went sleeping. My camera is SBIG STT-8300, so PHD must control it througth SGP API. When I woke up at 4 o’clock this morning, found the telescope stopped in meridian position, I realised something must be wrong. I found the sequence has been terminated, PHD showed the error message, just like this:

The message often appears before, and generally SGPro can automatically resume, but not this time.

I guess, when meridian flip was needed, an error occurred because the cooperation between PHD and SGPro, the result was the non-recoverable error.
Attachment is the log files, I hope it will help you to find the problem, thank you for your rapid response to Chinese users, thank you ~! (533.3 KB)

is your timeout value actually set to 61 seconds as the message would imply? if not you should definitely increase it - i have mine set to 100s.

on my STT-8300M i have sometimes seen the guider camera take more than 13 seconds to complete an exposure.


Thank you for the information . :smile:
I’ve tried setting timeout to 180 seconds, but the PHD would prompt 181 seconds error tip.
I suspect that there is a cooperation bug between PHD and SGP API.
Previously, my STT-8300M’s guider shutter could not open fully, but it never took several seconds to complete an exposure.


There are 2 issues going on here. Your flip did not fail due to a communication error with PHD2 (though I do recommend @pfile 's suggestion… I also recommend using the “Pause guider during image download” option to avoid PHD2 timeout issues).

The reason your flip failed was due to a bug for mount’s that cannot flip using normal methods. There was an issue in the “Wait for meridian” code that did not properly identify your mount as one needed a non-standard flip methodology. As such, it did not properly block the flip sequence until your mount had truly crossed the meridian.

[2016-3-12 2:36:24] [DEBUG] [Main Thread] Adding sequence level notification: Cannot Run Meridian Flip:
-Telescope must be pointed across the meridian to pier flip.

It was close, but the fix will ensure that your mount is actually across before continuing:

[2016-3-12 2:36:24] [DEBUG] [Sequence Thread] Meridian Flip needed, Hour Angle >= Degrees Past To Flip: -0.000780189050990643 >= 0

Thank you, Ken.
The first issue, PHD failed to complete the exposure throught SGP API, I’ve been using the “Pause guider during image download” option for a long time, and I’m sure that I have set the PHD timeout to 180s before but the PHD still would prompt the error message sometimes. Though my hunch is SGPro and PHD programs is blocked somewhere, I will try timeout setting 300s or more. :stuck_out_tongue:
The second issue, meridian flip error, I discussed this matter with iOptron developer, he gave me these words in ASCOM:

For many reasons, he found it difficult to support sideofpier property in a short time, and he suggested that the third-party software (just like SGPro, and so on…) perhaps would find a way to support more reliable control of meridian flip.
Ken, if you can help fix this problem please let me know. Thank you very much~ :smiley:

AIUI SGP has solved the problem of mounts not implementing set SideOfPier by waiting until the mount has tracked past the meridian, then doing a normal slew. Once the mount has tracked past the meridian a normal slew to the current position should do the flip.

Differences in alignment may mean that the position where the mount does the flip may not be exactly at the meridian, the way to resolve this is to allow the mount to track a little past the meridian, then do the flip. Try setting the “minutes past meridian to flip” in the Meridian lip Options to a few minutes past the meridian - 5 to 10 minutes - and see if that helps.


Thank you for your information, I and domestic users discussing the question, maybe caused by:
That night, I used the software to correct the polar axis, then synchronized the mount data, but is not accurate, then used the polar axis telescope to adjust, estimating is the process caused the mount data and actual location out of sync, causing the problem.
I’ll be careful moving Equatorial must ensure that the synchronized mount location data in the future.
Meanwhile, I would also recommend SGPro can automatically recover from the meridian flip error. That night, I set the automatic recovery, but it seems meridian flip error doesn’t belong to the range of automatic recovery.
Thank you all for your analysis and recommendations, I hope my photography can go more smoothly in the future ~ :grinning:


I think we might be having a communication issue. As indicated above, the problem you encountered with the meridian flip failure was a bug with SGPro, not iOptron and has been fixed in


Thank you very much~! :grinning:

1 Like

Hello, I have been using SGP without any problems until I upgraded my observatory PC. I got the message below and am not so sure how to solve this.

[07/11/21 23:38:33.487][DEBUG][Main Thread][SQ;] Sending Notification: Error - Cannot Run Meridian Flip:
-Telescope must be pointed across the meridian to pier flip.

What settings must I check to SGP and EQMOD? I am using an EQ8 mount with SGP version of v3.2.0.660.

Best regards,

Hi - I think there is a pinned thread on EQMOD settings somewhere, with all the settings you need.

Our documentation has a blurb about it. May be somewhat out of date but I believe all the settings are accurate still.


Thank you both for your feedback. I will look into it on my next observation run.


I have implemented the settings on the document provided and after several attempts, meridian flips fail and the telescope is parked for the night.

I have tried to alter the time for the flip between +4 to -2, to no avail. Could this problem be because of the ASCOM driver Prior to my previous PC upgrade, the system worked just fine. It is possible to load an earlier version of the driver?

Below please find a link to a log excerpt around the time of the flip.

Best Regards,

It looks like maybe your mount parked when it hit the meridian? Maybe something in the EQMOD settings that is preventing the flip?

[08/06/21 00:54:02.009][DEBUG][Sequence Thread][SQ;] Checking if Meridian Flip is needed
[08/06/21 00:54:02.010][DEBUG][Sequence Thread][SQ;] Telescope is on the West side of the mount
[08/06/21 00:54:02.010][DEBUG][Sequence Thread][SQ;] Presenting wait for meridian dialog...
[08/06/21 00:54:27.076][DEBUG][Main Thread][SQ;] PopulateDataModel:  Transferring view to the data model...
[08/06/21 00:54:27.137][DEBUG][MF Update Thread][SQ;] Performing serialize...
[08/06/21 00:57:26.315][DEBUG][Main Thread][SQ;] FlipWait: ending wait due to telescope parked or not tracking...


Hi Jared,

Problem seems to have been solved. Indeed it was a EQMOD setting as you suggested.

Many Thanks,