Fails Centering


I have found a few other discussions on the subject. I am having centering issue when the subject appears to be dead center any way. I have expanded the acceptance range and the number of trials and still cannot center before or after a flip.

I have located my log from last night and the associated sequence here.

Thanks for any suggestions.


It seems like your telescope cannot Sync for some reason, yet for the CanSync parameter it is stating it can. I’m not sure if this is something you need to address in the ASCOM settings or if this is something the driver manufacturer needs to address :

[03/30/19 22:11:50.695][DEBUG] [Telescope Thread] Telescope: Sync behavior set to "Sync"...
[03/30/19 22:11:50.799][DEBUG] [Telescope Thread] ASCOM Telescope: Invalid Operation Exception in Sync : SyncToTarget() RaDec sync was rejected. (System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Runtime.InteropServices.COMException: SyncToTarget() RaDec sync was rejected.

Hi Jared.

I have sent EQMOD a message regarding this. Are you able to see that my SGP settings are appropriate then?


I’ve had problems with EQMOD not wanting to sync before and it was always because the actual position in the mount was too far away from the sync point, maybe this is the reason for you too?

Actually what puzzles me is that the target is pretty well centered on the screen as the plate solving is taking place. And EQMOD gets synced by the sole & sync process of Answr and PS2.

Not entirely. Unfortunately I’m not a EQMOD expert. Best I can do is recommend this (2.00q should also be acceptable):

Thank you,

But I was asking if you could see from the SGP log that the SGP settings were appropriate. Do you see anything that I may have set incorrectly in SGP?

No, it is an issue with your EQMOD settings. SGP is solving and attempting to sync just fine. The failure happens when SGP attempts to sync the mount and the failure comes from EQMOD. This needs to be addressed in the EQMOD settings or in the EQMOD driver. Nothing you do in SGP will correct this.


These are my settings, latest version, and centering / flipping works fine. I have the encoders switched off for my AZ EQ6 btw.

Farzad, not sure if this helps or not but I had problems a couple of weeks ago for the first time plate solving. I was using plate solve 2 and EQMOD. Everything seemed to be working as normal, and my setup is the same setup (and profile) that I’ve been using for a lot of imaging. What seemed to be happening based on each plate solve iteration is that after an initial centering (still 200 pixels off), there was no correction getting through to EQMOD to the mount. Because the error was staying around 200 pixels off and at times getting worse. But basically hovering around 200. And I can confirm that the images were constant (were not moving between plate solve iterations) and looked centered (200 pixels isn’t that much on my cam). But my criteria is 50 pixels, so unless it centers within 50 it’s a fail… and usually this is no issue. I went through several runs and even increased iterations to 5. Again, no errors, EQMOD and the mount seemed to be connected just fine and up and running, but was making no corrections. So I shut everything down, and reconnected everything, and it worked fine. So my question, when doing this is the amount that the solve is off, going down at all or staying constant? If constant, try a restart. I reminds me of the days of microsoft blue screens of death restarts, but it worked and didn’t take all that much time.

Okay, thanks.

Thanks, I will definitely try that. My approach has been to park the scope and re-acquire the target, and that has not helped.

Chris of EQMOD responds with the following:

"IF EQMOD is rejecting the sync it will be because either the sync distance is just too large or perhaps because the sync is being made past the meridian.

*The fact that you are currently getting close to the target does not preclude a sync being rejected as too large - it could be that a large correction is already being applied and the extra bit you are requesting is just pushing it over the edge. *

Check the message center and see if there are any messages being posted - you could also open up the EQMOD ASCOM trace and filter on the sync messages to see what EQMOD is reporting back to SGP.

Presumable you have EQMOD in “dialog mode” for handling syncs. If so I’d start by clearing any pre-existing sync data in EQMOD and goto a star and see how close it gets - if it is someway off just slacken the clutches and manually reposition until the star come into view (if using a mount type with auxiliary encodes make sure these have been turned off). Doing this will refine your hone position and should ensure that any further centering syncs will only require small corrections."


Hi Farzad, yes, shut down and reconnect. I actually disconnected everything from eqmod and then shut it down and recycled power on the mount, then did an ascom /eqmod reconnect. Because I did try just restarting the plate solve from home position, without turning off the mount and reconnecting, and it did not work and ended up with the same results. I played around for at least an hour. Since I have no rotator, I thought maybe it was rotation… but after a while, the fact that my residual error didn’t ever go down, it was clear corrections weren’t being applied (not sure where the failure is). Once I re-powered and reconnected, it worked as expected.


I will definitely remember to do that next time. I am almost always also thinking about switching to INDI and get off the Windows/ASCOM system but I don’t know how well that would even work. I would be perfectly good with paying license fees for a platform like ASCOM and a driver like EQMOD if they became official. I am happy with the support, but I feel like they would be more robust if they were not freeware and product of passion alone.


Hello again. I have had another chance at trying to center my 0.38"/pixel system on Atlas Pro mount, being guided by PHD2 and it still fails to center. I also discussed on EQASCOM forum and I am not getting any useful answer. I am kind of suspicious of the resolution of the image being so small, and perhaps that could have something to do with it?

Here is the log file from last night. I am also reading it to see if I can understand it.

Thanks for any feedback.


Folks - When I had one of the original Avalons (SynScan), I just used Chris Rowland’s official ASCOM driver. It worked just fine. I had used EQMOD with an NEQ6 some years ago and I did not miss the additional features. I went in through the handset and just wrote a simple script to set it up for the time and date etc when I switched on.