Feature Request: Emergency Stop

Every once in awhile I get SGP ‘stuck’. Usually I start it too quickly, try to cancel it while it’s trying to do it’s magic, and it’ll get stuck in a loop of ‘Aborting…’ when it’s not actually going to stop.

Could we get a button that is a ‘emergency stop’ where it just kills whatever automation is going on and puts SGP back to square one?


I’ll go with this mads, had this happen to me multiple times & have to shut down SGP to get out of it.

But shouldn’t an ‘Abort’ do this anyway ?


1 Like

I understand the frustration, but the proper fix is to find which part of the sequence startup is not responding to the abort button. Abort is “Emergency Stop” so I don’t think we want to put another one on top of that.

What would be helpful is logs so we can see what the last item reported was and check into why it does not respond to abort signals.

1 Like

Good point you make, I will be sure to add any logs to this thread as and when I feel the need to abort for some reason and SGP appears not to respond in the expected way, I’ll also highlight why I decided at that time that an abort was required. Probably also useful to add my PHD2 log too if that is running as part of the sequence.

Due to sh!t weather in the UK over the past couple of weeks I have found myself setting up inside, just for practice as I’m very new to SGP, and creating profiles which use some of the available simulators in SGP but not all, is it possible for the EQMOD ASCOM Simulator for a mount or the camera simulator called ‘Simulator’ (set to the same res & pixel size as my QHY8L) to cause a problem with aborting ?.


Having never seen the issue myself, I am not able to answer that question with ant certainty. It is certainly possible thought (since we don’t do any testing with EQ software).

It’s pretty easy to replicate (for me). I’ll see if I can generate some logs. I have a day off.