FMW: camera angle text entry has no effect


  • open FMW
  • type my camera angle into the text (spinner) control under the Rotate selection slider.
  • fetch an object, frame it, create a sequence (with or without Auto rotate option)

The target will created be using the angle represented by the slider, not the angle I typed into the text box. The value typed into the text box appears to have no effect.

A related question: the angle in the FMW seems to be initialized to the actual camera angle modulo 180 degrees, yet the slider allows you to set the angle between 0…360 degrees. Is there some reason why the real camera angle is not being used to initialize the angle in the FMW? For example: if my camera angle is 83, then the FMW angle is initialized to 83; if my camera angle is 263 the FMW is initialized to 83 (yet I can use the slider to rotate to 263).


While I understand that this is not the most intuitive system in the world, it is functioning as intended. You must type a number and then hit Enter. This is done to facilitate a better user experience (so the rotation to get to 236 degrees does not go through arbitrary rotations… 2 to 23 to 236).

I can’t reproduce this one. The control panel camera tab has 45 degrees in it. The MFW opens with 45 degrees of rotation.

Actually looks like this does happen when the angle is over 180…

Thanks Ken, I see that it works when I hit enter. So… feature request: can you have the entry take effect when the spinner buttons are pressed and also when the control loses focus?

yes, exactly. it looks like it is initializing the value with camera angle modulo 180.

Sorry to be a pain here, but the reason I’m making a fuss over this is that last week I entered a value in the text area and tabbed away and proceeded to frame a mosaic. The result was that the framing did not match my actual camera angle, and I went off oblivious to this and collected many hours of data (18.5 hours over 3 nights) that was incorrectly framed due to the mismatch between the angle in the FMW and the real camera angle. I only discovered the problem yesterday when I started to process the data and the panels were not square :scream: so I pretty much have to throw the data away :cry:. I should have been more careful and validated the framing after a few subs but the FMW has always been totally reliable for me and I had come to trust it. This will never be a problem for me again because I know about the Enter key and I have been burned too badly to forget, but I would be surprised if somebody else does not fall into the same trap that I did.


I think I can do the loss of focus event, but the spinner buttons may be a different story since they are hooked in to the “value changed” event that I was trying to avoid in the first place. But… shouldn’t loss of focus be enough since it would be impossible to create a sequence without clicking on something else?

Maybe I will just hook up to the value changed event with a timer. No changes for 1 second and apply the angle. That would probably be more intuitive.

Also… don’t think I’m invalidating the issue… I will add additional handling, but… I’m not quite sure how the error was introduced and maybe you can help clear that up so I make the issue is really fixed.

So… you entered a value in the spinner box and it didn’t “take” (this is not in dispute). But… There was some type of image rendered for you to draw a box around. You drew the box and clicked create sequence. The sequence was created with the angle that you drew on (true it was not the one you were after) and that should have coerced your camera to that angle and the tiles should have matched up.

The way you describe it, it sounds like you drew your box on one angle then a sequence of another angle was created and I’m not sure how that is possible. Were you not using automatic rotation when the target started (you have a mechanical rotator right)? Did you replace the angle with something else?

Ken, no problem, as far as I recall it happened like this.

  • I was using my second camera with a fixed angle. No camera rotator (not even manual rotator). The camera had been off the scope so whatever angle was in the profile was off from its actual angle.
  • When I opened the FMW I suspected the angle was not right so I took a frame-and-focus image and plate solved it. I pasted the camera angle from the plate solve into the text area. Then I clicked on the object name, entered FoV, and clicked Fetch. (from here on I was doomed !)
  • As I dragged the panels, the fetched image was at the old camera angle (angle text entry never “took”), yet I saw the plate-solved value there in the text entry so had no reason to assume I was drawing on an incorrectly rotated image.
  • Next, I created the sequence, leaving the “auto-rotate or validate rotation” option un-checked since the camera is fixed and I have no intention of rotating it.

So I think it’s pretty clear how I got in trouble, and there was never a case of the box being drawn on one angle and the sequence being created with another.


OK. This is done. Inactivity in the box (via typing or the spinner) for around 1 sec will update the angle. Loss of focus will update it immediately. Should be fairly impossible to replicate the situation you found yourself in above (will be released in the next 2.4.3. beta).

Thanks! :thumbsup: