Focus issues with recent updates


I have about had it with these focus errors after this rash of updates in the past month. Where do I find an older version at least 2 months old before this started? I never had focus issues before.

Aprox time of issue:

Link to Logs

Useful Info

OS: Microsoft Windows 10 Home
.NET: 4.8

Go to: Archived Releases SGP Scroll down and take your pick which one you best feel will help you.

Your problems more than likely comes from bad settings or hardware issues, the new autofocus routine tell you there is something wrong instead of just continuing after a bad autofocus like it did before.
The usual problem is a step size which is too small, the highest HFR should be around 3-4x the lowest HFR in the graph, you seem to be at lowest HFR 2.8 and highest 5.

What kind of scope do you have?
If you have a reflector remember to turn off smart focus.
I cannot see backlash being turned on in your settings, this should definitely be turned on, even if one doesn’t need it, it won’t hurt anything.

With the settings you use it won’t autofocus good with an older version either even if it seems so, it’s just that it won’t tell you the focus run isn’t optimal

+1 I find the new focus algorithm is more reliable with all my refractors and reflectors. Some ideas:

  • make sure your AF exposures are sufficient to get enough identified stars
  • step size is all important; dog ears suggest too many/too big and a very small HFR range suggests too few/too small
  • if the slope either side of the focus point is assymetrical - highly indicative of a collimation error.
  • manage backlash - either in the focuser module/driver or in SGP but not both
  • set minimum star size so that it is just sufficient to reject hot pixels; if it is set too high, stars suddenly do not register as they get close to focus and the mean HFR result is ruined

None of the info on this thread helped, tweaking suggested settings did not help.
I am running 2 rigs, a refactor and an RC . Both have moonlight focusers, I can watch them move and everything is working normally.
I can manually focus in SGP with no trouble but auto focus failed every time but once tonight with multiple setting tweaks, the one time it did complete and give a green line it was way out of focus, about 300 steps.
The oldest version I can go back to is .428. I installed and would not start up. I found in my downloads, it would start up but in not compatible with my sequence files.
Prior to the updates since December I had no trouble focusing or getting good images, now I am getting crap and can’t find a hardware issue to explain it. If there was a hardware issue the odds that it would happen on 2 rigs is not likely.

Looking at the focus data in your log file there’s no indication of a minimum in the focus values.

Your focus positions vary between 3055 and 2905 at 30 step intervals and the HFR seems to vary apparently randomly with a value of about 4.

If that HFR is what you expect when in focus then the step size may be too small. and what’s happening is that you are just rattling around the minimum. Try defocusing manually until you get a HFR of about 10, note the difference in focus position between that and the position at focus and divide by three. Set that as your step size.

Or set a step size of 100.

The previous focus routine ‘worked’ because it could never fail. If nothing else it just chose the lowest value and random variation always came up with something. Your long focus systems have a large CFZ so almost anywhere was OK.


That worked on the 10" RC, it’s been running all night.
It worked on the refractor (Mead 70mm astro) also set at 100 at first, but after a few focus runs as the temp changed it went down hill.
After repeated runs the reported step positions keeps going down. Started out around 14000 a cpl hrs later it was down to 9000. I thought something was slipping but everything seems tight and looks like it is moving well.
I’m wondering if the the moonlight stepper motor could be reporting position incorrectly.

Good to hear that increasing the step size worked.

The MoonLite focusers can slip and this can give what you see - repeated focus positions further in.
One way to tell is to move the focuser fully in to the stop and ensure that it is zeroed at that position, then focus again. If it’s back to the expected position then the focuser may be slipping. It’s possible to adjust the focus shaft tightness but do so carefully. Consult Ron Newman for details of how to do this.

I’ve never seen the firmware report an incorrect position, or the motor itself miss steps but do need to adjust the shaft tightness occasionally.

What Chris said.

Moonlite focusers aren’t that great for imaging, they do slip and if you tighten them up to the extent they don’t then the anodising quickly wears out and the motion goes rough.

Be careful not to over tighten or you’ll wear through the anoising pretty quickly.

The Rc is working fine and that focuser has been working great for a year.
The refractor is still a problem and that is the one that is changing with each focus run.
the refractor has a rack and pinion focuser that can’t slip and my moonlite stepper motor is turning.
I checked it today and everything is tight and it is moving freely.
I have tried everywhere from 15 to 120 steps and still can’t get auto ficus to work on it.
Not sure if the lof file attached.

Ron suggested that I clean the serial cable ends, there could be moisture of corrosion interfering with communication. I cleaned the serial and usb plugs and sockets with electronics cleaner. All seems to be working well again.

Could it be the coupling from the motor to the focuser slipping?

If you have access to a digital caliper you can test for repeatability easily and accurately. With your gear attached run the focuser out to somewhere around half way, but pick a round number that’s easy to remember. Measure how far out the focuser tube is, run it in and out a few times, return to your half way position and measure again, it should be exactly the same as your initial half way measurement.

Cleaned the serial plugs with contact cleaner, problem solved. 4 of the pins transmit position data, one bad connection = erratic position reports.