Focus issues

I have a Focus Lynx focuser that I have used in the past. I recently added another focuser board and got a new motor (duplicate of one I already have).


  1. The PDM motor step size is 2.3microns, but the sgp log file reports 1,xx microns
  2. With a step size of 100, I can always reliably get to focus using @focus3 from The SkyX
    3 I have tried 100 to 125 step size, and the autofocus from SGP is unable to reach focus. I get a message to the effect that “we are lost, moving to best guess focus” and image is visibly out of focus.


a) Why is SGP asking for a step size from the autofocuser instead of the user? Perhaps there is a Fw bug in the motor or its controller that give in correct step size.

b) I tried various step sizes with the control panel. The CP was successful with autofocus of 125 but when I added to an equipment profile (and saved if ofcourse), I could not get the same results, Why?

c) Now I am lost, please suggest next steps.

Shailesh Trivedi

This isn’t used by SGP. I wouldn’t worry about it too much.

These are 2 different systems and likely need 2 different types of values for focus.

If you can post some logs or images of your auto focus graphs we can help to get you straightened out.



Please check if you can download the log file from the link above.


Hi Shailesh,

I took a look at your SGP logfile with Mikael’s very useful software, SGP Auto Focus LogViewer (see SGP AF Logviewer v1.2 Release ).

In Auto Focus Options you set the following parameters:

AF Run	Data Points		Step Size
  1		    10			   125
  2		    10			   100
  3		     7			   100
  4		     7			   125

Please change the number of DataPoints to 9. There will be no need to modify this value again.

The Step Size that you chose is too low. I estimate that in your case a StepSize of about 175 steps will be appropriate. Assuming that the initial AF curve is symmetric, i.e. the curve is well-centered, the right setting is found when the relation (maximum HFR value / minimum HFR value) is about 4. E.g. if your minimum HFR value is 0.80, the maximum HFR value shall be about 3.20. When this relation is < 4, increase the Step Size. If it is > 4, decrease it. When the appropriate Step Size for your equipment is found, it doesn’t need to be changed again.

One prerequisite to a well-working Auto Focus is that previously you set the focuser backlash appropriately. In SGP you should set this value somewhat larger than the really occurring backlash: the set value must not be smaller than the real value, but it doesn’t hurt if it is somewhat larger.



This is great insight, thanks for this. I tried to increase the exposure to 10 seconds and got successful run last night with 100 step size but as you say, this s not the cure, I will try 175 and 9, to see what I get, I will save your post, since this is very helpful.

I will also be sure to use the AF log viewer.


Probably my estimation was not quite correct, and the optimal Step Size is about 200 steps. However you got to try it compare the results.



I tried with 200 steps, 275, 300, 400. None give consistent repeatable results. Perhaps my backlash is too low (40). I am at a loss since it is a pure guessing game. My subs have messed up focus when smart focus fails and SGP uses best guess focus.


Backlash has to be set appropriately before you try to adjust the step size in Auto Focus. As I wrote above, this is a prerequisite.

Did you try as well with the option ‘Disable smart focus’ checked?

In order to make further recommendations, I would have to see some AF graphs (or a SGP logfile).


I tried backlash of 40 and then 100. No difference. I tried to check Disable smart focus in the control panel and it still is doing smart focus, so this option does not work.

I will try to upload a file to drop box

Here is a link to drop box for the log file

OK, the AF runs #16 to #21 of this logfile clearly show the cause of the issue. I append the graph of AF run #16:
This is the succession during AF run #16 (settings: Data Points 9, step size 400, the initial focuser position is 320549):

  1. Focuser moving OUT by 1600 steps to fp 322149, capturing AF frame #1.
  2. Focuser moving IN by 400 steps to fp 321749, capturing AF frame #2.
  3. Focuser moving IN by 400 steps to fp 321349, capturing AF frame #3.
  4. Focuser moving IN by 400 steps to fp 320949, capturing AF frame #4.
  5. Focuser moving IN by 400 steps to fp 320549, capturing AF frame #5.
  6. Focuser moving IN by 400 steps to fp 320149, capturing AF frame #6.
  7. Focuser moving IN by 400 steps to fp 319749, capturing AF frame #7.
  8. Focuser moving IN by 400 steps to fp 319349, capturing AF frame #8.
  9. Focuser moving IN by 400 steps to fp 318949, capturing AF frame #9.

There are NO focuser backlash compensation movements. The first two inward movements (2. + 3.) do not alter the focus position at all, they are needed to take up the focuser backlash. This is the reason that there is no change of the HFR value after the first and the second inward movement. The logfile also shows that focuser backlash compensation was disabled:

[10/12/20 18:28:36.826][DEBUG][Main Thread][NONE]

So you will have to enable Focuser backlash and set focuser backlash value to about 800 steps. Please let the option ‘Disable smart focus’ checked. These settings must be saved in the equipment profile and in all sequences using this equipment.

The focuser step size of 400 may be a little bit too large; presumably a value in the range of 200 to 300 is more reasonable.

I am sure that you will get fine AF runs when these recommendations are followed.


Thank you very much for your continued support, Bernd.

How did you extract the steps 1 to 9 of Run16? I used SGP Auto Focus LogViewer but could not get the summary so succinctly like yours.

Dumb question: I used the Settings tab in Control Panel to set the backlash, looks like it did not get applied. It should either have been 40 or 100. Is there another way to apply backlash? I also used the Focus Boss’s Focus Lynx Commander app to do the same. But still looks like that did not work.


In order to get the details displayed in SGP Auto Focus LogViewer, press the button ‘Scan details’ in the main window.

The settings for focuser backlash are made in Control Panel/Focuser/Other (see SGP Documentation PDF file, p. 48, 49). The option ‘Focuser backlash compensation’ must be enabled, Compensation direction IN, and in your case Compensation step size has ti be set to about 800.

In order to save these parameters for the current sequence, you’ll have to save the current sequence subsequently.

For a given equipment profile, the parameters are set in this order: open the Equipment Profile Manager, select the Equipment Profile that shall be changed, then set the options in Control Panel/Focuser/Other as described above. Subsequently you’ll have to save the altered Equipment Profile.

You can ‘apply’ an Equipment Profile to a sequence, see SGP Documentation PDF file, p. 97.


Hi Bernd,

Thanks for your note. After some frustration of not being able to focus, I plan to resume my attempts again. Can I not use the control panel to try different options? Save sequence with equipment profile does not work is new information for me.

If CP overrides equipment profile, I can try it via quick experimentation.



Reporting back. I changed backlash to 800 (step size 200), and here are the results (success).



AF Run Date Time Pos HFR Temp Filter Q (min Q) Misc Target

File ID = 20201115002452
1 11/15/20 00:25:58 320239 1.12 4.8 Lum 98% (90%) Successful
2 11/15/20 01:35:03 320251 1.34 3.8 Lum 99% (90%) Successful Bubble Nebula
3 11/15/20 02:43:19 320241 1.26 3.1 Lum 99% (90%) Successful Bubble Nebula

Also attaching visual from auto focus log viewer.

Bernd - thank you so much for your help and persistence in staying with me.


I am glad that it works for you now!