Force calibration PHD2 on meridian flip

Could an option added to the meridian flip setting to force PHD2 to perform a recalibration?


It is certainly possible to add this option, but I’m curious as to why you would need it.

I’m not sure why but sometimes the guiding is too far off after the meridian flip. I can’t find a cone error in my setup and also the Reverse dec output after meridian flip option in PHD2 doesn’t seem to prevent it. When it happens I lose half a night (and the clear nights in the Netherlands are very rare). Better be safe than sorry…


Running a calibration during an unattended imaging run has risks of its own, so we recommend running your calibration manually and before the imaging sequence starts.

If you want to post your PHD2 Guide Log in the PHD2 forum we may be able to offer suggestions in that forum. It would be most useful if you could post a log that shows a calibration run on each side of the meridian so we can compare the two calibrations.

I would also like to request this feature. I am using a Skywatcher EQ8-R as my mount, and it is… finicky when it comes to autoguiding. The new multi-star guiding by PHD2 has been a godsend and I have found that clicking the ‘recalibrate after target change’ has solved a lot of my problems… until the meridian flip. Then it will restart the guider and all is well until it starts trying to guide and forces the star off in a wild direction. If I’m not watching it, the sequence fails and it runs end of sequence options. I’ll restart the sequence and it will recalibrate the autoguider with no further issues. So either another checkbox for ‘Recalibrate after meridian flip’ or for it to recognize a meridian flip as a target change.

Just a thought - have you checked “Reverse Dec output after meridian flip” in PHD2?

Also might be worth posting on the PHD2 forum - in case it is a PHD2 issue. They are generally very responsive there.


I have tried that before with no success. However, after reading through these forums last night, I saw that someone recommended checking the box then closing out PHD2 in order to force the change, which is a step I have not tried before. I’ll have to wait for a clear night to try it.