Forcing Focuser Driver Update

I have an HSM stepper motor on the focuser of my NP 127. The motor is controlled by a Pegasus Astro Ultimate Powerbox v2. SGPro talks to the UPB which runs the focuser.

In Equipment setup the choices include “ASCOM Pegasus Astro UPB Focuser” which has historically worked for me when running PAs UPB software.

PAs new Unity software needs the “ASCOM Pegasus Astro UPBv2 Focuser” driver. That is not an offered choice in SGPro. I know the driver is on my PC as the PA software runnning standalone operates the focuser properly.

How do I get/force SGP to offer the UPBv2 driver as a choice?

SGPro will offer anything found in the ASCOM registry as a choice for use. Take a look at the ASCOM Profile Explorer to see what it’s reporting.

Many thanks Ken. Problem solved.

I checked the ASCOM Profile Explorer and only the old driver was present (in this case no “v2”). Did an uninstall of the Pegasus Unity software followed by a full reinstall. Before firing up SGPro I checked Profile Explorer to confirm the the v2 driver was present. It was and, as you explained, it was available as a Focuser choice in SGPro.

Great work I continue to enjoy using SGPro.

1 Like