Getting an error when plate solving reference image

Hi there,

I just installed PinPoint and was having issues with plate solving. In the Target Settings menu, I have tried using my own FITS file, even tried the astrobin and Flickr plate solved links found in the user manual but when I click “solve” I get this message: Failed to plate solve: Object reference not set to an instance of an object.

This message only appears when only astrobin and flickr links.

When I use my own FITS files and click on Solve, I get this message: Failed to plate solve: Solve Failed! The time limit for plate solving has expired.

If anyone can help with this, I’d really appreciate it!


Hi Sal

I use PinPoint and I’ll try my best to help. Can I ask a couple of questions?

  1. Which version of SGPro are you using?
  2. Can you confirm that you have the GSC1.1 catalogue fully installed with the correct file path structure? (See the DC3forum page here if you haven’t used it as an aid already, Is this set in the equipment profile?
  3. Have you set your image scale in your equipment profile? It needs to be relatively accurate and can be calculated; this website will help and has the formula,



SGPro is sometimes complex in its behavior. We won’t be able to provide much assistance without logs. Please attempt to solve, grab the logs and post them to Dropbox or similar.


  1. I am using version
  2. My GSC is installed and directed to C:\GSC11
  3. Yes I have the image scale set pre the image i was solving.

Ken, here are the logs for when attempting a reference image and astrobin link;



You appear to be using an unsupported version of SGPro. Can you please upgrade to 2.3 and try again? We have better logging in the 2.3 version.


Hi Ken,

After updating to the latest version, I was able to solve the astrobin linked images but still not my own images.

Here’s the log after updating and attempting to plate solve my image:

Also, I am able to use my own reference image and do a blind solve but cannot do so when just solving.



The logs indicate that you are not providing pinpoint with any RA or Dec hint data.



Do you mean the image I am referencing doesn’t contain RA DEC hints? I was able to blind solve the image using but not when just solving using PinPoint.

Yes, Pinpoint is not a blind solver so you need to provide RA and DEC hints (which your image does not contain or we would find them and auto populate the RA and DEC hint fields). Because of this, you need to populate these fields by hand before clicking solve. Any image taken with SGPro will have these values in them (assuming you have an ASCOM telescope connected when the image was captured). Please see the help file on plate solving for more information (found under “Sequencing” and then “Target Settings”.

[7/5/2014 11:10:21 AM] [DEBUG] [PS Reference Monitor] Plate solving reference frame...
[7/5/2014 11:10:22 AM] [DEBUG] [PS Reference Monitor] Plate Solve Hint RA: 0
[7/5/2014 11:10:22 AM] [DEBUG] [PS Reference Monitor] Plate Solve Hint DEC: 0
[7/5/2014 11:10:22 AM] [DEBUG] [PS Reference Monitor] Plate Solve Hint Scale: 2.311
[7/5/2014 11:10:22 AM] [DEBUG] [PS Reference Monitor] Plate Solve Hint Angle: 0
[7/5/2014 11:10:22 AM] [DEBUG] [PS Reference Monitor] Plate Solve Search: Use up to magnitude 20 stars

Hi Ken,

I now understand what the issue was. The telescope wasn’t connected to the computer when I took the reference image, therefore it not having any RA and DEC hints. That’s why it fails. I’m glad this was resolved before I went out to discover the issue during a session.

Another question I have is that after I have created a sequence using the Framing and Mosaic Wizard and set up the exposure parameters (time, filter, etc) and click to begin the sequence, will SGP slew the telescope to the target with the coordinates from the wizard? I believe this the auto centering, correct? This is all assuming I have already run the 2+4 star alignment on my scope.



Yes. It will create a series of sequences as required and plate solve to center them.