GM2000 Failing to flip

I am having trouble with the meridian flip on my setup, which is a GM2000 mount. I have attached the sequence file along with pictures of all the relevant settings. I looked at old threads and tried everything from them to no avail, including changing between J2000 and JNOW, tweaking the values, etc.

Any tips or hints how to fix this would be most appreciated. Last night was my first clear night in weeks and I lost half of it due to a failed meridian flip :frowning:

Relevant bits:
[06/18/17 23:13:56.590][DEBUG] [Sequence Thread] Checking if Meridian Flip is needed
[06/18/17 23:13:56.690][DEBUG] [Sequence Thread] Telescope is on the West side of the mount
[06/18/17 23:13:56.690][DEBUG] [Sequence Thread] Meridian Flip needed, Hour Angle >= Degrees Past To Flip: 112.928458333333 >= -2.5
[06/18/17 23:13:56.690][DEBUG] [Sequence Thread] Running blocking meridian flip…
[06/18/17 23:13:56.811][DEBUG] [Pier Flip Thread] Meridian Flip: Starting Meridian Flip Procedure
[06/18/17 23:13:56.813][DEBUG] [Pier Flip Thread] Meridian Flip: Skipping Solve
[06/18/17 23:13:56.814][DEBUG] [Pier Flip Thread] Meridian Flip: Stopping the Auto Guider
[06/18/17 23:13:56.816][DEBUG] [Pier Flip Thread] Meridian Flip: Sending Telescope command to execute meridian flip
[06/18/17 23:13:57.070][DEBUG] [Telescope Thread] ASCOM Telescope: Pier side is West
[06/18/17 23:13:57.070][DEBUG] [Telescope Thread] ASCOM Telescope: attempting pier flip using sideOfPier
[06/18/17 23:13:57.597][DEBUG] [Telescope Thread] Setting Pier East
[06/18/17 23:13:57.919][DEBUG] [Telescope Thread] Pier Flip failed when using side of pier: System.Exception: Flip requested but cannot be done at present position.
[06/18/17 23:14:28.985][DEBUG] [Telescope Thread] ASCOM Telescope: Failed to flip because starting pier side and ending pier side are the same!
[06/18/17 23:14:29.236][DEBUG] [Pier Flip Thread] Meridian Flip: Telescope command to meridian flip has completed
[06/18/17 23:14:29.236][DEBUG] [Pier Flip Thread] Meridian Flip: Telescope failed to perform meridian flip

sg_logfile_20170618205142.txt (711.9 KB)

-10 degrees is effectively saying “10 degrees before the meridian is reached”. Is this what you’re intending?

[06/18/17 23:13:57.919][DEBUG] [Telescope Thread] Pier Flip failed when using side of pier: System.Exception: Flip requested but cannot be done at present position.

This error seems to indicate that your mount, for whatever reason, cannot reach the current location if the flip were to happen. My guess is either a hardware or software limit.

Also 10 degrees on either side of the meridian seems like quite a bit. But you know your equipment better than I, so maybe this is obtainable?


The choice of -10 degrees was chosen based on another thread I found, but searching now I only find this one which recommends -5. I have tried that as well before, but I’ll try it again tonight and see if it helps.

FWIW the Specs page says the mount can go up to 30 degrees past meridian.

You may want to take a look at your ASCOM driver and see if there is a limits area inside of there. I know my G11 has software limits that I can set and so do many other mounts.


You may want to check “wait for meridian” and auto center under settings. Also, when I wrote my post, there was a firmware bug that 10u found. When the mount would hit the meridian, the “hand” would show up on the hc indicating the mount had stopped and would not flip. This has been corrected.

I would also set the “time to meridian flip” to “0”. All of this can be tested during the daytime. Your log is indicating that it can’t do the flip due to it being on the same side of the pier.

Also, go to the 10u forum and look up my posts under “PJ” regarding this problem…Gunny

Thanks Gunny and Jared.

I will try getting an updated 10u firmware as I am currently running 2.13.16. The weird thing is flips used to work, and the only thing that changed (afaik) is updating SGP. However, maybe a setting got changed by mistake?

In any case I have enabled “wait for meridian” and auto center* I set “time to meridian flip” to -5 for now, if that doesn’t work I will try 0 next. Hopefully I will have updated firmware soon, currently I cannot access that part of the 10u forum. I’ve messaged their admin to get that fixed.

  • The SGP dialog under “Auto Center After Meridian Flip” says "Will perform a ‘Solve and Sync’ prior to the meridian flip. Is the tooltip here a bug and should say “after” the meridian flip?

Last night the flip worked. I hypothesize that it was the new 10u mount firmware, but I also made two other changes:

  • Changed from -10 to -5 before meridian is flipped in SGP settings
  • Switched back to J2000 from JNOW in the mount driver. JNOW was causing the mount to completely mispoint when first slewing, requiring a blind solve. I had assumed there was some protocol wherein the app (SGP) and the mount negotiated the protocol to use, but now I suspect there isn’t one, because last night, when using J2000, the slew and center solved immediately without needing to failover.

In any case, success! Thanks all for the tip on updating the firmware and other suggestions.