Goodnight System Problems

I have been trying to get the GNS system to work with my observatory PC. I have the SGP trial up and running: I have ticked all the boxes in the ‘Notifications’ window. I downloaded the ‘GNS Free’ App to my iPad to check that I could make a connection. I have not been able to make any sort of connection. In the App, I simply get the ‘Waiting For Communications’ message. No communication is ever established.

I have used ipconfig to determine my host name and entered this into the App. All other settings are as per the Instruction Manual on the GNS website. I have tried manually assigning a permanent IP address to my observatory PC. This didn’t work. Windows Firewall is turned off. I am running Win 10 Home. I am not sure how to proceed.

I am aware that GNS should not be running when SGP is started. I am aware that GNS will not start via SGP until a sequence is running (I have been running a ‘Flats’ sequence to test the system.) When I could not get SGP to run, I did try downloading and running the Windows GNS program. The instructions tell you to run ‘update’ via the command prompt to test the system. I have to report that this did not work either. I got some sort of message telling me that something was amiss on ‘line 5’ (whatever that means).

I have contemplated getting an AAG Cloudwatcher, at some point in the future. Does this require GNS to be working or does it communicate via a different system? I’m a bit reluctant to purchase something if the software from the company cannot be made to work on my machine.

Whilst not directly related to your GNS queries gnomus, I have the AAG Cloudwatcher connected to the Lunatico Solo. This enables the weather data to be pushed to a web interface and I can check on the conditions, including safety switch, independent of logging via TV to my obs pc. You can also set a static ip address so that it can be viewed outside of your own network.

Just some further thoughts for you on accessing your weather station data instead of/as well as GNS.


I would start by getting GNS to work outside of SGPro entirely. Go to the SGPro install directory and double click the “GNSUI.exe” application and try to connect the mobile app from here. Once this is resolved, running via SGPro should not be an issue.

Thanks both for you responses. I will try running GNSUI outside of SGP and let you know how I get on. It may take me a day or so…


one more thing, you mentioned using ipconfig to input your host name in the App. In local network, it should be the IP v4 address (4 numbers), as the iPhone won’t be able to find a windows name.

Once you’re accessing from the internet, if you have a domain name for your observatory (maybe a dyndns or similar) then using the name in the App will work.

Best regards,


Thanks Jaime. It was the 4 number name I was using, but I think I may have figured out what happened. As I walk to my observatory, my iPad (which I was carrying with me) lost its connection to my wireless network. It then connected to a BT FON network, which made me think I was still connected. I managed to get it working. Now I need to try it properly and make sure it works as I hope.

Thanks for the help.

Brief update. It still seems to be working. I know that two cameras is not (yet) supported. Nevertheless, I have been imaging with two scopes. It seems that GNS starts and works fine when I run the sequence on scope 1. However, when I start the scope 2 sequence, GNS turns off.

I am not expecting a solution (unless there is an easy one). I simply wanted to make folks aware so that if dual imaging was supported at a later date, you would know that this is one of the ‘issues’ you may need to consider. Perhaps you are already aware, in which case, I apologise for wasting your time.

Thanks again


Never wasting our time to report findings like this. This makes sense as both SGPro instances are using a common GNS resource. We will need to look into a better way to share this…

Hi Ken, Steve,

mainly to apologize for my lack of response - I was expecting to be notified of these messages?

I’ll have to check my forum settings.

As Ken said, the reports are never a waste, much welcome. And great to know the main problem was solved.

Multi-scope support is quite a thing… I’ll keep thinking on it while I finish what’s holding me to address the new GNS :slight_smile:

Best regards!

No worries Jaime. I can report that GNS seems to be working. I got a notification the other night when cloud rolled in and PHd lost the guide star. As such, I have purchased the full-price App and will be buying te SGP add-on when the trial expires.

Thanks Ken,

for my part I can report the email notification of the forum does not work :wink: … or should I say as expected, a bit confusing the watching / tracking difference to me. Whatever, watching the thread now.

Do not hesitate to contact me should you have any issue with the GNS.

Best regards!