I can't get SGP to do an auto meridian flip anymore

I recently updated SGP to, and it can’t do an Auto meridian flip anymore. When it gets to the meridian, it doesn’t flip. I didn’t have this problem with the last version of SGP I used; it flipped just fine. Also, the behavior of the “Use Auto Meridian Flip” checkbox seems to be a bit odd.

Here are the details of my setup:

Mount: Losmandy G-11, Gemini 1, Level 1.4.

Scope: 600mm f.l., 80mm aperture Orion ED80 refractor.
Guide scope: Orion ST80 with StarShoot autoguider camera.

Imaging camera: SBIG ST8300M mono camera with LRGBHa filter wheel.

Laptop: ASUS eee PC 12-volt netbook, running Windows XP

Mount-control software: Gemini.NET control software. When I click “About”, it says ASCOM Gemini Telescope Driver Version

Autoguiding: PHD2 version 2.2.2g. When I went to openphdguiding.org to get this latest version, it told me to download version of the Gemini.NET controller, so I did.

(In other words, I updated SGP, PHD2, and Gemini.NET at the same time. My problems with auto-flips started as soon as I installed these software updates.)

After several months of being too busy with work to do any imaging, I decided to get the gear out and try to re-learn my workflows. I had had good luck with SGP the last few times I’d used it. Everything generally worked together pretty well, and the auto meridian flips generally worked well.

However, after the software updates, SGP doesn’t flip when it reaches the meridian. I have the auto-flip set to 0 degrees past the meridian, so it should flip, but it doesn’t. Another odd thing is that when Auto Meridian Flip is checked, I don’t get a countdown to the flip; I just get “NA”.

This can be seen in these two screenshots: The first one shows Auto Flip enabled, the second one shows it disabled:



I didn’t change anything about how I used SGP, at least not as far as I can tell. I also think that the Gemini.NET program is working okay, since its virtual hand paddle reports the scope on the correct side of the mount, and it gives a correct-looking hour angle. (When the scope is West of the mount, shooting in the East sky, it shows a negative hour angle, whose absolute value is getting smaller as time goes by.)

There’s another slightly odd thing I noticed in SGP, which may show up in those screenshots… I have the dither enabled, and SGP says it is, in fact, dithering, but there’s a dither icon at the bottom of the screen that looks greyed out. Same for autofocus. That icon is greyed out, but the autofocus is working.

I have “Center On” and “Slew To” enabled, and the sequence begins just like I’d expect it to. A panel of annunciators comes up, and shows that SGP is plate-solving and centering on the target frame just like always.

I think the mount is correctly synced. I polar-aligned the mount with PEMPro, and I have done some “solve and sync blind” operations, with “sync performs additional align” enabled in the Gemini.NET program. Since the G-11 is correctly reporting the side of pier and the hour angle, I think it has a good GoTo alignment. PHD2 is able to calibrate and autoguide as usual.

Here are the log files from tonight’s attempt. They may look a little odd, since I made a number of attempts to test this behavior. On two or three occasions, I used “Solve and Sync Blind” to populate Target Set 1 with a new image and coordinates, since all I cared about was testing the ability to flop.

Another slightly odd thing from my workflow might show up: I begin the night by using SGP to do a crude 1-star alignment with Solve and Sync Blind. Then I disconnect SGP from the gear, and use PEMPro / Maxim to do drift alignment. Then it’s back to SGP for the actual shooting. However, I do at least one more Solve and Sync Blind (with Sync Performs Additional Align) after I reconnect the gear to SGP, so I think the mount has a decent idea where it’s pointed.

Here are the log files:


I’m sorry that I don’t have the sequence file. I closed up the unattached garage where I do my imaging, and I can’t get back out there to retrieve the file from my imaging laptop without waking up the neighbors. I will try to attach it to another post tomorrow.

Sorry for such a long message, but I’m just confused as to why Auto Meridian Flip stopped working. I hope I’m just boneheading something simple. If this proves tough to diagnose, I might try to revert to earlier versions of SGP, Gemini.NET, and PHD2, to see if I can get back to my good `ol reliable software and workflow.


The exact same thing happened to me a little while ago, also right after
I updated PHD2, SGP and the Gemini.net ascom drier all at the same
time. I was never able to identify the actual problem, but in my case I
was able to resolve it by doing a cold start and re-building a simple
pointing model using 3 stars in the east and 3 in the west. Since doing
that I’ve had no problems. I would also check your time and timezone

The problem is with the ASCOM driver. It has a known issue where it reports the incorrect side of pier for the G1 (I also have this mount).

You should revert to the driver on the ASCOM site.


Hi Joel and Jared,

Thanks very much for the tips! I’ll start by reverting to the driver, and reverting to an earlier version of PHD2. Hopefully I can test that tonight.

I’d like to try re-building the pointing model with the current Gemini.net driver, but I think it’ll be more practical for me to down-rev some of my software first. My setups are always temporary, whether at home or a remote site, so I’m always looking for a fairly quick & dirty way to sync the G-11 to the sky. But the next time I’m at a multi-day star party, where the scope&mount don’t move for several days, I think I’ll try building a more thorough model.

  • Marek

I’m using the latest version of PHD and it seems to be working ok with You may give that a try as well but no guarantees.

Personally I haven’t built a pointing model in about 2 years…and I have a permanent setup. As long as your polar alignment is decent a single star sync is likely more than adequate. This of course assumes that you’re using plate solving with Auto Center.


Thanks heaps for the suggestion, Jared - it worked! :slight_smile:

I went back to the Gemini.net program, and to an earlier version of PHD2. (I think it’s version 2.2.1.) After drift alignment, I used Solve and Sync Blind to designate some random piece of sky as my Target Set 1, and let SGP shoot 1-minute subs on it. Sure enough, the countdown to Auto Meridian Flip was present, just like it’s supposed to be. And it flipped! :smiley: Man, I love watching those auto-flips! I kept an eye on the cables while the mount flipped, to make sure nothing hung up or tugged, but otherwise everything worked just like it’s supposed to.

It’s a bummer that the Gemini.net program appears to have a side-of-mount bug, but maybe that’ll get fixed at some point. For now, though, my SGP workflow seems to be back in business. Life is good!

  • Marek