I'm having so much difficulty

I’m having trouble getting my moonlite mini v2 to connect to Sgp . 4 nights and over 20hours , I see the moonlite DRO in the dropdown now , My mini v2 motor focuser and my lxd55 won’t connect now {error in connecting message. My # 704 750 7119 Ronnie. I have run into a road block , device manager says there working properly , still won’t connect Help ? Anyone.

I would start by disconnecting all other devices and start by connecting them one at a time. Verify you have the correct com port in the ASCOM settings for each driver and then attempt to connect it. Also make sure you’re not running any other applications that are connected to that device (through ASCOM or natively).

Also you can attach a log if that fails and we can take a look. Info on where to find logs and good info to include can be found here:


Jared , thank you for your speedy reply , I’m totally bewildered on this one . I’ve had the telescope connection problem [1} time before back in the Spring {multi reboots} nothing besides the weather has stopped me from enjoying Sgp through the Summer and Fall maybe because I didn’t have the moonlite mini v2 till the middle of November , I might be having a driver conflict a buddy told me . I didn’t start having trouble connecting the focuser with Generic hub and all looked well it even started running a focus routine on m42 but , it wouldn’t run a sequence. I had it linked to trusty old FM I knew something was conflicting with a driver when I restarted testing and the telescope wouldn’t connect when I was going to try Sgp focus aide. I got a hold of Ron Newman and he instructed me to download the moonlite DRO rotator driver also . So , I did and after a lil’ while of shutting down everything " It showed up in the dropdown ," error connecting" for both the focuser and the telescope connection . PHD connects The QHY and on-camera {mount} . I’ve hit the wall Jared , can we teamviewer again and you can actually see what it’s doing, my dropbox keeps telling me wrong PASSWORD and it won’t allow me to change it or I would attempt to send something but , it doesn’t look like it .

I’ve seen various devices refuse to connect or only connect intermittently, and the root cause be a powered usb hub that I thought had power, but actually didn’t.

The hub will sort of function, via power from the usb input cable, but maybe not properly power all the connected devices.

So, if using a powered usb hub, make sure it actually is getting power (power light is on even when input USB is not connected). If using an unpowered hub, maybe you need to switch to a powered one?

Thank you dts350z , I use a usb 3 {7 port powered Atolla with individual power buttons to power each port : my Bluetooth for mouse , Bluetooth for 10" firefox backlit keypad , pole master and my mini v2 are all connected to it. The telescope connection goes from hbx to 507, to my 232 adapter, to serial to usb cable into computer port usb 2. My mount and everything except computer is on a 6 outlet Belkin power surge protector. Maybe I need to put the mount on my battery to dual outlet ? I’m just reaching now , frustration has gotten the upper hand . I’m getting ready to connect it , fingers crossed still have everything showing working in device manager , urggg and neither will connect . HELP ME PLEASE ! I’m feeling pretty darn stupid RIGHT NOW.

I’ve tried everything except uninstalling Sgp and re-installing it Jared , I really didn’t want to have to do it , do you think that’ll do it ? hopefully I can put the info in correctly this time.

All devices you can’t connect too i’d say you should test them directly connected to the pc, not through a hub.
Even if a hub appears to work ok and there’s no errors in device manager that doesn’t mean it actually works as it should.
FYI most connection problems people have can be traced back to bad USB hubs or bad USB cables.

FYI the another usb issue(s) I’ve have are related to different ground potentials from different device power supplies.

The solution is make sure all supplies have a common ground, to prevent different potentials at the device causing data issues and/or current flowing in the ground of the usb cables, sometimes damaging the cables (especially if they are active).

In the field this is easier as everything is powered off one battery (or if two or more batteries by connecting ONLY the negative terminals together). If you have things that run at other then 12v you can us DC to DC converters and connect the negative side of your output dc to your common negative.

I would agree with the above comments on potential usb cable and hub issues.

Given that it seems like your problems started when you introduced the focuser into the equation I suspect the powered hub was not up to the task of supplying enough power. Or perhaps the extra data communications of the focuser was enough to overload the usb data network.

Not all powered usb hubs are made the same. I’m not familiar with that particular brand and would suggest trying a different one such as StarTech (especially their industrial versions). Or try running direct to the PC and bypass the hub (especially for the focuser) - at least as a means of narrowing down the root cause of your issues.

I’ve had intermittent problems in the past - for instance it will seem to work ok for a while and then decide to quit/disconnect. Always resolved those issues by replacing usb cable(s) or using a better powered usb hub.


Xplode , thank you for your response. I have an Atolla 7 multi port usb3.0 data splitter and quickcharge hub with 5gbps download speed and with a 5.4A power adapter provides up to 2.4 Amps charging power with stable data transfer. I researched all kinds and went with the atolla 7 just what I needed, it has been good until I got the motor focus. I only plug certain devices to it but, now I have a motorfocus and I’m trying everything you fellas reply. I just might have to get a Startech hub but, I’ll try replacing cables 1st.

Dave thank you for replying , I’m not ruling that out . I’ll switch some of the usb cables , I’ve got a couple xtra backup cables just for this reason . I just may have to get a Startech hub but, cables are going to be tried 1st.

It was the connector cable from the autostar to the serial to usb cable connector that was bad , I need to think about replacing that cable about every 9 yrs. That’s not bad for a connector cable being pulled and tugged on every night I’m out. Everything connects now , while I was setting up a sequence , my focuser disconnected . Is that common or is something wrong ?