Installation of ansvr local problem on Windows 7 system

I cannot use port 8080 since I use that for another program (ACP web logon). I tried changing to port 8081 and then 8082 but these failed, even though these are not in use and I set up port forwarding in the router for each. The log shows "cant set up server: Address already in use at /opt/ansvr/ansvr line 1076."
Any advice would be appreciated.



Port forwarding in the router is unnecessary. The communication between SGP and ansvr is entirely local to the PC, no network traffic leaves the PC or goes through the router.

Here is an ansvr-related post with a method to find in-use ports.
Here is another post where somebody found that the problem was caused by Windows Firewall.

Please give those ideas a try and if neither one solves it we can investigate more.



I found an unused port and ran the ansvr_log.bat. It showed that the aqnsvr
is acceptingf clients on that port and is waiting for data.

However when I ran Sequence Generator-control panel-platesolve, ansvr was
not in the dropdown menu.

What am I doing wrong?


Dr. Larry Simpson
Emeritus Professor
Geffen School of Medicine at UCLA
Microbiology, Immunology and Molecular Genetics
3825A Molecular Science Building
609 Charles E Young Drive East
Los Angeles, CA 90095-1489
Cell phone: 310-709-8972

Hi Larry,

You’ll need to make sure you have SGP configured to send the requests to the port where ansvr is listening.

Take a look at the SGP setup instructions on the ansvr install page. In the part where it shows how to copy/paste the endpoint URL into SGP, make sure you use the port number you have ansvr listening on, and not the default port number 8080. For example, if you are using port 7070 then your endpoint URL in SGP would be: