Interface glitch driving me mad!

Hey all,

There is an issue with SGP’s interface which drives me mad.

This is what it looks like when I start up:


Lovely !

Here’s what happens if I open up the settings for a target:


Still Lovely, the settings box is nice and squarely positioned over the sequencer.

Here’s what happens if I bring up the Planning Tool:


GRRrrrrrrr…Over half the box is off the bottom of the screen and I have to grab the
bar at the top of the settings box and drag it up the screen so I can see it.


I fully appreciate there are more important things on the list but it would be great to
sort this one out for the sake of my sanity LOLOLOL Or, SGP’s interface has that
‘Pro’ look (which is why I use it :heart_eyes:) This though ruins the ‘Pro’ look.


1 Like

It’s not a glitch, it’s because of your placement of the sequencer window low on the screen.
Move the sequencer window to the center of your screen and this won’t be a problem

Same issue here, if I don’t remember to move the target settings window the planning tool is off the bottom of the screen.

Well… The idea for its current placement is that location and time controls remain visible. There are certainly ways around this, but none that I think look ‘Pro’ as you say.

I moved the Target settings window all the way to the top but just below the Tool bar, and still I cannot see the “OK” button on the Planning tools window.

My monitor:

1920 x 1080 at 100% text size.



Maybe you could provide a screenshot?

The reason I have the sequencer at the bottom rather than the center of the screen which I think was it’s initial default position is mainly because I sometimes have some floating modules which are not locked to the sides because they just dont fit, so I open them when needed and close them when finished. These floaters I usually position up higher so if for any reason I was to open the sequencer it doesn’t cover them up, pretty reasonable I think, we are all different. Putting the sequencer up high and my modules down low is also doable but I dont like it like that as much.

I see your point about having the time controls visible at the same time though, also very reasonable.
With all due respect to APT, as it was the first software I used, but I was never totally happy with the way it worked and how it looked especially, the interface felt a little cartoon’ish to me, one day I accidentally stumbled across SGP and there you have it, hooked in a second, it was that polished pro looking interface, sorry Ken but for me SGP is PRO Woooooo HOOooooo

Back to this issue - Certainly not versed in complex programming, but, based on the position that each individual person likes to place their sequencer, when the Planning box is about to open up, is it aware that half of it’s box will be off screen ?? If so, and in my case with the sequencer being at the bottom, could the planning tool not open up and be ‘above’ the time controls in this case ? Or maybe the settings box could jump up a bit to ensure the whole Planning box is visible ?


Just tried my 19" laptop which runs at 1920 x 1080 and there’s plenty of room for the Settings / Planning Tool box here.


Alright… Because 3.1 is close to release, I am only allowing for quick and low risk changes (defects aside). Here is the compromise. It now opens like this

A little exclamation will be there is there are warnings or errors to see. If you want to read them, click the button to expand:

Hopefully, this will refund enough vertical space that it won’t drive you mad.


IMHO, this is a glitch or bug in the GUI (graphical user interface) design. There is good design and there is bad design. You should never lead the user into these “traps” or corners from which he or she cannot escape. You won’t see these errors in Adobe, for example.

And Adobe had 9 billion usd in revenues and 20,000 employees. The comparaison makes little sense.
That being said I know nothing of software development.

Folks… relax. We didn’t say this wouldn’t be addressed, I just stated that this was the compromise for 3.1. We have to stop at some point and release. This is not a blocking issue.

1 Like

While I agree with this sentiment, while we address other issues for 3.1, anyone finding themselves in this situation can just hit the ESC key and be back in business.