Issue centering an image (Beta 8)

Hi all, need a little help on this one and apologies for all the screenshots – not sure it’s a bug, or more likely user error. I have an AP1100 mount, and use local set to J2000. Using a QSI683; Frame/focus bin2x2. Using Framing and Mosaic Wizard, I framed a target (M96) and created a sequence:

So far, so good, imaging on night 1 goes without a problem and centering the scope goes fine, for example:

On night 2, I’d like to use a night 1 image as a reference because I might nudge the scope from the original F&M setup to get a better guide star. So loading an image taken from night 1 and plate solving, I see:

If I right click and center here, I see this (which is where the problem lies):

Initially I was thinking this is an epoch JNOW/J2000 issue, but because this is a “closed loop” (F&M > Astrometry > My Image > Astrometry > My Image) I didn’t that would be the case. The only other thing that comes to mind is the binning used in F&F. I tried this a few times with the same result, I wasn’t awake enough to try setting Astrometry to JNOW or 1x1 binning.

I did save the F&F image above, and when I plate solve it, I see the plate solver is correct which makes me think it’s not a plate solve issue but binning/image scale issue:

I had another target where I centered on a night 1 frame and noticed the same thing. Any ideas?

Thanks much,

There are some issues with “Center Here” when using We generally recommend using Pinpoint or Elbrus for this. We’re aware of them and are working to fix the issue.

However you can do what you’re after by setting your previous night’s image as the reference for the target. That will get you centered on the object without using the right click “Center Here”. The issue only affects “Center Here”.


Perfect, thanks!

I’ve experienced the exact same issue last night with my AP Mach1 mount (also using a local solver)

Does this issue also happen using internet as well?


It sounds like Jared is on top of this, but I’m not quite following and am curious about what the issue is.

In the screenshot under this, what exactly is the problem?

It’s not centered where it is supposed to be. On the screenshot above the line ‘(which is where the problem lies)’ the galaxy is centered. Right click and center here is in the screenshot below, showing the galaxy way off center.

I only had a few moments last night due to clouds but tried as Jared suggested and it worked fine.

I guess what I don’t understand is that if you right click and center here, it will center on wherever your mouse was when you right clicked. So just to make sure, are you right clicking very near the centered galaxy to reframe the galaxy, or are you right clicking somewhere further away from the galaxy? Sorry if I’m confused about this…in any event I’m glad you have the workaround.

Nevermind, I get it now. (been up too late lately!)

Actually that’s a knowledge bomb. My assumption has been that when you right click and say center here, it doesn’t matter where the mouse is, it simply centers based on the current image. I looked it up in the manual and … wow, had no idea it worked that way. Nice!

So honestly not quite sure if there is still a problem as I wasn’t paying attention to where I clicked. That said, the better approach is what Jared said – use the image itself as the reference in the sequence options. I was just winging it to play with some framing.

(Not to add feature bloat, but perhaps 2 center options – center on mouse, and center on image. Not that you can’t accomplish the latter by simply right-clicking in the middle of the image, but seeing the choice might prevent those who didn’t read the manual fully from making long forum posts.:))

I wondered about that from the very beginning of the thread. It does say Center HERE, which is logical to me. But like you said it’s much better to use an actual image for the plate solving, rather than rely on a freezing cold, shaky hand to right click on a certain spot.

hang on - so where is “here”, if not where the mouse pointer is?
I definitely tried to click on a certain spot in the frame, and expected the next capture frame to be centered THERE (as you would in MaximDL for example), and it did not work for me. the scope seemed to slew to the wrong direction, despite the fact that it plate solved correctly both scale and rotation

That’s probably the issue that Jared highlighted above.

in the meantime… what is the default way of fine-framing a target for which you don’t have an image already? iteratively bump the mount and re-image?

Agree, sounds like Jared is on it and there is likely a bug but not exactly as I thought. It’s great functionality, to be sure, and makes sense that ‘here’ is where the mouse is.

To be honest, and I’m not sure if this will make sense, but left click is often action specific to where the mouse is (draw here, type here, select here) while right click often contextual as a whole (close image, exit, print, etc). I wasn’t conciously thinking this at the time, but that’s the best explanation I can think of. Now, if I saw center here on a left click, I wonder if I woulve thought differently?

I’d rate that method about third on the list of good ways to frame a target. I would:

  1. Use the Mosaic and Framing Wizard. This is probably the best way and will get you centered and precisely rotated with extreme accuracy
  2. Go to and find somebody else’s framing that strikes your fancy. Copy that URL and enter it into the Target Settings reference image text box, then click Solve
  3. “Bump and Shoot” Run frame and focus, with your favorite paddle and stop when it’s done. Plate solve, then choose, use solve as target reference image.


Try the Framing & Mosaic Wizard. Once you try that you’ll probably never use anything else!


while I might consider purchasing the MFW at some point, I find it troubling having to buy an add-on to get around a bug in the core application.
The suggestion also is not feasible as I’m usually imaging away from home and internet access.

Point & frame really should work as advertised. If MaximDL can do it (and that software really is a piece of junk) I really expect SGP to deliver on this.

Fair enough, but many people buy the addon expressly for this purpose and not to work around a bug.

Most folks arrange their sequences well in advance of leaving home so that might be an option for you.

Well it doesn’t… but not for lack of trying. We have looked at this for a while and nothing sticks out so we are having trouble fixing it. I have provided you with 3 other viable options and Jared has provided you with 2 (Using Elbrus or Pinpoint). So… we have a bug that is hard to track down and then we took time out to give you no less than 5 viable alternatives. We try to look out for our customers not irritate them.

Sorry that you are having a frustrating experience… we are doing our best. We really are trying to help.

Elbrus or Pinpoint work just fine with Center Here. Both of those are viable options and Elbrus is free.

We’re aware of the issue and it is SPECIFIC to Give Elbrus a shot if you prefer to use Center Here.

Also the issue with only appears at certain angles…which ironically don’t align to a 90 degree quadrant which is why it’s been very difficult to nail down.