Issue with 245 - Unable to save flats as a normal user

Tried to take a sequence of flats, but as a normal user, I get an error that I’m unable to save the flats to the equipment profile, which it ‘thinks’ its located in ‘C:\Program Files (x86)\Sequence Generator’ see below, which is to be expected for a normal user.

When starting the application it correctly loads the profile from local user\app data, and everything works as expected (from my limited testing).

If I run the app as Administrator it will save, what appears to be a copy of the profile to the Program Files location.

ERROR MESSAGEsg_logfile_20190919113913.txt (238.2 KB) .

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.UnauthorizedAccessException: Access to the path ‘C:\Program Files (x86)\Sequence Generator\ZWO 1600.sgp’ is denied.


Hey there… just a note that I’ve seen this and I’m looking. Windows “Program Files (x86)” is a protected directory but admin accounts are permitted to write files there. Somehow SGPro is opening your last sequence and then forgetting where it was… Not exactly sure how, I can’t seem to reproduce. Could you please check something that will help me figure out where to look? If you open SGPro (assuming it loads your last sequence), without doing anything else, just temporarily change any parameter in your sequence and try to save it. If that works, it will help direct where to look.

Hi Ken,
yes it opened the ‘current’ running sequence, & I reset an event progress count & saved ok.

sg_logfile_20190919152256.txt (16.0 KB)


Still not able to reproduce this issue… That said, I did clean up a bunch of code that is responsible or this behavior. Will continue to look.

Hi Ken,

At least there is a workaround, i.e. copy back the ‘Admin’ equipment profile from Program files back to the local profile, which works ok, and then create the flats as per a normal user…


So you are able to regularly replicate this behavior? If so, maybe you can provide details on a series of actions you take after opening SGPro.

I’ve literally just updated to .247, after first copying to backups of program files & appdata folders then un-install.

Installed .247, ending with open app, all appeared ok but obviously missing equipment profile, sequences, layout config, plate solve 2 etc.

Closed app and copied over, backing up any existing files:

sg_ui_config.xml sgpro_setting.json PlateSolve2.exe PlateSolve2.ini comdlg.ocx to \AppData\Local\SequenceGenerator

Copied PlateSolve APM files to \AppData\Local\SequenceGenerator\APM

Copies home.sgu ZWO 1600.sgp ZWO 1600.sgp.bak to AppData\Local\SequenceGenerator\Sequence Generator Pro

Copied Sequences folder to AppData\Local\SequenceGenerator\Sequences

Re-started app, and all looked ok with the layout, current “running” sequence etc. checked Options & Control Panel \ Equipment Profile all OK.

Then open Tools \ Flats Calibration Wizard but on selecting the Equipment profile, I’m presented with the “Warning ! Continuing will open a new sequence…” window.

On clicking ‘yes’ a different system error is generated “The path is not of a legal form”

Continue returns to the wizard but number 2 window is empty, Close kill the whole App, not just the Wizard.

Hope this helps

************** Exception Text **************
System.ArgumentException: The path is not of a legal form.

FYI, I’ve had to roll back from 247 to .245, as I was unable to create a new sequence, with profile, and getting the same non legal path error…

I tried re-building Profile from scratch & re-saving, which appeared to work ok, but would not create a new sequence with profile…


Yes… making changes while tired I guess. The fix for the first issue caused the second. Got it all patched.

Thanks, will test after I’ve sorted out my OAG…