Issues with blind solver (local)

Hello, I am having some issues with the local solver.
Platesolve2 works well when I have the proper hints. (online) will blind solve my images.
I am running the most up to date ANSVR 0.19 and confirmed with the updater.

I have two optical setups I use with the same camera. One has a scale of 1.92" and the other is 6.73" with 3326 pixels. I have index 1.42-2 degrees to 5.67-8 degrees installed. I do have the correct scale entered in the camera tab.

Blind solving for my wide field setup (6.73") works great and solves in about 20 seconds. The 1.92" images will usually timeout when doing a blind solve. It used to work well for me up until a few months ago.

I have the ANSVR configs set to default.

Let me know what other information I can provide to help diagnose this issue.


here is a failed blind solve log (1.92")
sg_logfile_20171023011316.txt (138.5 KB)

here is a successful blind solve log (6.73")
sg_logfile_20171023012708.txt (25.9 KB)

Same issue with local ANSVR not solving.
This is quite a mystery to me because ANSVR has been the only solver I have used for the past 2+ years and it has always worked flawlessly. I used Platesolve2 a few times for testing purposes and it worked well, but ANSVR solved for me in 5 to 8 seconds ALWAYS so I just used it. Never failed. However, a couple of weeks ago it was failing on perfectly good target images and rather than try to fix it, I just shifted to Platesolve2 which worked immediately and I have been using ever since.
I did make an effort to fix it by increasing the hint error from 2% to 5%. Didn’t help. I had not made any configuration changes to ANSVR.

Well looks like I figured it out… helped by an accident. :slight_smile:
I uploaded one of the images from the 1.92" optical setup to and looked at what index it used to solve the image. On the results page it said that it used the index. At that point I mistakenly read the 211 as 210, so I download index 4210 from the index manager… and then it worked. I guess I did not have a large enough buffer.

So now that I am rereading the instructions, I am realizing I did not follow what it said- " Choose the size correspoding to about 20% of your narrowest FOV"

I have a 106.432 arc minute wide FOV. I thought it meant choose 20% error of my FOV which is ~85.14 and then selected index 4211 (85’-120’) as my narrowest.

If I followed what the instructions say, that would mean I should select down to index 4206 (16’-22’)

1 Like

And I have shifted back to ANSVR. Last night Platesolve2 would not solve several images for me even though it was very close to the requested coords and the prior solve a little further away had solved ok. When I stopped Platesolve2 at about 1500 and restarted it, it solved very quickly. Go figure. Shifting to ANSVR solved perfectly for the rest of the session, including the target that failed with Platesolve2.