Keeps Crashing During Download in Sequence

I was temped to add to Lisabrrtt’s posting since my issue sounded similar to hers, but I did not want to hijack her thread. Her post can be found here:

My issue, like hers, is with Version Infrequently, while running a sequence, a failure occurs during image download. When this happens. SGP disappears from desktop and task manager (Win 10 Pro). The image is not downloaded. This setup has been operating without issue until recently - added a focuser and I have been running the TEC harder (near 100%). The failure is fairly infrequent and mostly random - but I have only seen it occur on 10 minute exposures (and not on any of my 4 minute exposures). I have linked log files (one successful and two crashes) in the dropbox folder linked below.

To recover, I need to start SGP again, close it right after opening (for a normal termination). reopen again, connect the camera, start the TEC, connect everything else, and continue with my sequence. I usually have to power cycle the camera as well. Phd2 (still guiding), filter wheel, focuser, and mount comms are all still operating without intervention.

Camera, filter wheel, guide camera are connected directly to the computer; focuser and mount are connected through a 4 port hub. Last time it occurred in the field, I switched to another laptop and proceeded without incident (no log for this - it got deleted after two weeks). One thing I notice in the two logs for the failures is that the log ends at the debug entry
“[Sequence Thread] Restoring system standby state…”

I strongly suspect a hardware issue or computer configuration issue but the infrequent and somewhat random nature of the failure makes it difficult to isolate. I am hoping you can provide a hint as to where likely suspects may be. I the meantime, I ordered a USB isolator for the camera USB connection to try.

Jim T.


You could be right about the system standby state. I have never seen that before, but it seems suspicious. That said, it might also just be a side effect of a bad USB bus on the computer. In both crash logs, the camera suddenly disconnects without warning. As such:

[11/20/19 12:47:17.983][DEBUG] [Equipment Connectivity Thread] SGPro thinks the camera is connected, but it's not, syncing UI...

This is indicative of either a bad driver or a bad USB port / cable. Add this evidence to your trial run on the different laptop and I think I agree with your suspicions.

It is probably still worth it to follow the suggestions in the thread you posted… specifically about updating the camera driver and then with a trial of SGPro 3.0 (one at a time).

I have had similar problems however my failures have occurred over numerous iterations of SGP. I am currently using version Most of my failures occurs when I am using frame and focus. I use windows ten which is always up to date. One problem I have notice is I have had to start SGP on a freshly booted computer. This has helped a lot in reducing crashes. Also I notice crashes with frame and focus when I was doing alignment on my mount. I never remove my filter wheel or camera. I use them to align the mount. But some times I brush up against the USB cables and get a small noise that the camera has doped out. Some times I restart the camera with success and other times I have to close SGP or even reboot the computer. I now tape my USB cables to prevent any bump in power which helps a lot. My laptop is six years old and I replaced the hard drive with a ssd. I have used various cable and hub combinations with no real improvement. I now use a powered ten port general data hub with a good quality 10 M USB 3 cable. I have the latest drivers for my Atik camera and filter wheel. Despite restarting the computer, securing the cables running the latest Ascom drivers I still get unexplained crashes. I have checked the logs and not found any thing. This week after a successful run of imaging I went to do a run of flats calibration wizard and had SGP crash without warning. My weather conditions this time of year are cool ( -2 - + 8 ) and high humidity. I have noticed that I must use chooser for the Ascom Telescope driver For my Celestron mount, I do not know if this is SGP related or not no other Ascom driver needs this. One thing I am trying is to wait for the camera to finish cooling before I do any thing. Hope this helps some one.

Hi guys, mine sounds very similar to emelans. Heres whats happening with mine (only since i got a new motherboard). I start up SGPRO first thing I do is frame and focus usually 1 or 2 secs it takes the shot downloads and if you look at the bottom left of screen the green bar freezes at I think star analysis (though it could be on download). sometimes it works ok but 9 out of 10 it dont, sometimes it just takes ages.the camera is connected direct to pc and every driver is up to date, I should add that nothing is ever removed as its in an obsy, I have just tried out running it from a freshly booted pc and it worked but im going to run it a few more times like that as it could have been a one off. will let you know the results update** seems like it was a one off cant even download once now

just a further update as it might help someone, I downloaded an older version of sgpro and although slow (it seems to stall on star analysis) the frame and focus turns grey and says not responding then my image appears . So for me at least the older version is working better than the newer one (which went a lot worse)

I want to update this thread with my troubleshooting results on this crashing issue.

I tried a USB isolator (high speed capable - USB 2.0) - no impact or improvement.

I was also worried about the reliability of the automotive “cigarette lighter” style plug. I replaced it with an Anderson PowerPole connector. (probably a good idea on its own, but did not impact or improve on the issue)

I was able to get reliable reproduction of download failures by doing frame and focus (looping) of 1x1 bin; 1 second exposures - failure would occur on the first or second download. Funny thing is that Artemis Capture would still connect when SGP would not. I began to suspect the Atik 383 camera’s ASCOM driver. I had previously described that when I first encountered the issue in the field, I switched to an older computer and saved the imaging session. The offending ASCOM driver was version; the older computer’s driver is I installed the older driver on the offending computer - bingo! Solid as a rock. Now I don’t know if just re-installing the 7.0.7… would have had the same result (because perhaps the drive simply became corrupted somehow). I did not try to again install the 7.0.7… ASCOM driver. I was getting good stability on the setup now with the older driver so I didn’t want to disturb it. (Those of us working with re-installing ATIK drivers know how finicky they can be to get them installed.)

So It seems I am back to a reliable setup. Thanks for everyone’s help.

1 Like

I’m having an issue with my ASI1600MM saving images that are blank (another thread) but in the process of trying to trouble shoot, I ran into an issue that’s related to this thread.

I switched from the ZWO driver to the ASCOM driver to see if the issue continued. While running a sequence for 5 minute darks, I plugged a portable USB 3.0 drive into the laptop to download some images, which it did. SGP was integrating a sub when I connected the HDD and when that sub finished, it hung on the download and never downloaded the image. So I cancelled the sequence and restarted it - same thing happened at the end of the first sub. I then disconnected the camera in SGP and started again - still hung on download. I had to shut SGP down completely, restart and now it’s working again.

It sure seems like there’s some funny USB conflict activity going on, but I’m no computer expert. I’m using Windows 10 with all the latest updates on a more or less brand new Dell Inspiron laptop.

Are you saving to a network drive or just locally? I will try this with the ASCOM simulator to try and determine if that behavior is with SGPro or the ASCOM driver (they both write to disk).

Ken: I’m saving the files coming from SGP straight to an SSD on the laptop. I plugged a 2TB SSD into the 2nd USB3.0 port in the case I was describing above.

Now, having said that…I did another run trial last night and into this morning using the ASCOM driver and it ran fine with no blank images or download issues. Just to temp fate, I plugged that same 2TB drive into the laptop this morning while it was capturing a dark and the sub downloaded just fine and I transferred files to the portable HDD. I unplugged the drive and waiting and SGP continued to operate normally. So it appears I’m good with the ASCOM driver.

I’ve been having problems with USB ports in windows 10 for some time now and I’m sure a big part of the problem is Windows and how it handles all that.