Lost all my pics last night! Need help!


<Took an entire night of pics last night. Was watching it take pics and everything seemed fine. Pics are always saved to a thumb drive. This morning on the thumb drive there is this huge hierarchy of folders but NO images. it was broken down into Light, Flat and Bias frames. Each of those folders broken down into filter type, Then a bunch of folders with %frame number. Then in those was another file with a number and it’s empty. I can’t believe I have lost a night of data. The only thing I did different was added the flats wizard as a new target instead of appending it to the original target. Lost hours of perfect data on a perfect night. It has never done this before. I am using an Eagle 3Q and the images don’t appear to be on there either. Argh.

Link to Logs


Useful Info


Logfile shows you successfully took a bunch of subg/flats. Proble might be with your FILE_NAME scheme.

Each file was saved as “.fit”

I don’t use a mac, so can’t help you with how to ‘find’ the files in each 0180 folder. Windows allows users to save a file with blank filename and and extension - have no idea if Mac does.

From logfile…

Created full file name (file does not exist): D:\SanDiskSecureAccess\Andromeda Galaxy 2\Light%frame8\OIII\NGC2359_ Thor’s_Helmet\2020-01-31\0300\.fit

So, good news. I’m going to be able to save all the data. I can find the .fit flies on the Windows computer but not on the Mac. Bad news, I’m having to go in and rename every single image which is taking hours. Here is what I don’t understand. I didn’t change anything about my file name designation before that night and it has always worked perfectly. Now the last two nights, instead of adding those designations like date, filter type, etc onto the file name, they are being made into individual folders. So after you get through to the 6th subfolder, all you get is a .fit file with no name on it. Anyone have an idea what is causing that? Same thing happened last night and I had to manual,y rename every image as they were being taken.

the files are also there on the mac. the problem is that any file beginning with a dot is hidden in unix and by extension the MacOS finder. you can turn on display of these so-called “dotfiles” in the finder by opening the folder containing the file and typing “cmd-shift-dot” meaning, hold down cmd and shift while also typing a period, and the files should become visible. maybe if you just do that key sequence in the view you’ve screenshotted above all the directories with the hidden files will then show the hidden files.

there are ways to automate all the file renaming so you don’t have to do them one-by-one…

Thanks! I feel like by the time I have this hobby figured out I will have a degree in electrical engineering and computer science. I have most of the files converted now but now I want to figure out why on earth it is putting these into all of these darned folders instead of putting it in the file name. Literally no idea…

What’s happening is that your file name specification string is finishing with a ‘\’ character which the system treats as a directory separator. The file name after that is empty. Then the system adds the .fit extension leaving a file name of ‘.fit’ which the Mac treats as hidden.

The system is doing exactly what you told it to do.

Learning a bit about how computers work, in this case how the file system works, isn’t unreasonable. You are trying to use a computer to manage a complex automation process.

Well thanks. Guess I won’t be asking for help on this forum again. Was looking for help, not a lecture on my computer illiteracy. I don’t criticize people because they can’t read their own X-rays. I will fix the file structure. Only reason I was confused was because I didn’t change anything and it was working fine until 2 nights ago. Obviously something got changed and I didn’t realize it. For your information I have taught myself this entire hobby completely on my own. First and last time I ask for help. I will just figure it out myself as I have done everything else.

Glad you could find your data.

No idea why things would change all of a sudden, but then I’ve had just about everything happen to a seemingly bullet-proof setup. Nothing is a frustrating as doing 5 nights of imaging and then it craps out for whatever reason.

This is the naming schema I use : %tn\%tn_%ft_%el_%fe_%dt_%02

SGP has a cool little goggle icon that you can click to verify naming structure…

Thank you very much! I will try your file structure and see if that works.

well i’ve definitely accidentally typed characters in different fields in the sequencer panel, so i guess it could have been something like that.

I had this same problem. It turned out that SGP had changed some of the file tags in a recent release. Tags that I had been using for years no longer worked and caused files not to ve saved. Details here: SGP "Failed to save image to disk" Error - Beginning Deep Sky Imaging - Cloudy Nights

Interesting! Maybe I am not crazy after all.

I have had the naming scheme issue also. For what it is worth, when I do change the string for file naming, while I am waiting for it to get dark enough to PA, I just take a 30 second exposure (Doesn’t matter if it is overexposed) and just check the directory and file to be sure that the naming process is what I want. Then I know that I am good until I change it again.

Good idea. That was what was so frustrating though because I hadn’t changed anything literally since I first set SGP up. So it must have been an update that did something wonky. I will for sure run tests next time BEfORE running a whole night of data.

…or you could click on the magnifying glass and view the Path and File name Preview (no need to take an exposure).


Closing due to inactivity. If this is still an issue, please send the requested information and “uncheck” this thread as solved.