Mach1 - unpark fails at the start of a sequence

Starting a sequence from a parked position fails systematically with an error message appearing after the dialog asking if I want to unpark the mount.
Apparently, SGP knows the mount is parked, hence the dialog.
Has anyone met this issue before?
Mach1 with SGP - AP ASCOM drivers up to date, not using APCC.

If you can post a log of it, we can see what message (if any) SGPro is getting back from the request to unpark.


For safety reasons you must not unpark from a parked position unless you are present. Doing so will cause the driver to prompt you, which will stall an ASCOM client.

You should only need to unpark from a parked position if you released the clutches and moved the scope, or are setting up in a new location. Otherwise set the driver to unpark from the last parked position. The mount will not lose position even if it lost power so it is safe to unpark from last parked position.


Hi Ray, indeed, my message was probably unclear: I would of course always unpark from.the last parked position, this is the intent.

The issue I face is that SGP fails to unpark, but will check the driver settings again.



So I did check and the AP driver settings are correctly positioned, unpark set to “unpark from last parked position”.

Logs file in the link below.
Repro steps:

  1. launch SGP
  2. load sequence
  3. connect mount through ASCOM driver - (mount is parked) - Telescope panel confirms parked state, unpark button availabe
  4. Target settings > Slew Now
  5. Dialog “Slew to Target” > Yes
  6. Dialog “Slew to Target” - The telescope is parked or not tracking, would you like to unpark? > Yes
  7. Error message:

Note that clicking on the Telescope Panel > Unpark button does work correctly, and unpacks the mount.