Major problem with SGP apparently not connecting with N step

I have run into a major problem with SGP.
I have a 1600MM connected, an HEQ5 connected and the Nstep autofocusing system connected. All used to work fine
When I try to start a sequence from a profile that has been planned with all that equipment, I get an error message that says:
“error connecting to No environment device! Object reference not set to an instance of an object”

What does this mean?? The object has been specified in the sequence, is centered , everything is working and then bam I get this message when trying to launch the sequence. It is very frustrating!

I tried to create a new sequence for the same object using the profile and I get the same message.
I tried rebooting the computer and starting all over and nothing prevents this from showing up. It has ruined many hours of my rare imaging opportunities.
Can anyone tell me what is going on? and how I can prevent this from happening?? Until I figure this out, SGP is pretty much useless to me.
SGP version

Do you have an environmental device? Might the setting to have one be turned on by mistake? Check the sequencer to see.

Click by my “black” arrow if you don’t see Environment in the sequencer.

Thanks Steve but No environment device was selected.

You probably have the option set to use the environmental device for temperature. Click the “other” button on the focused control panel and deselect the option for the environmental device at the bottom.


Thanks Jared

As a matter of fact I think I did select that option thinking it was the temperature probe on the nStep. I will deselect promptly and test.

Yes the focus temperature will automatically be within the docking module for the focuser.

Revisiting this thread in case someone else runs into the same problem.
Do not select the option ““use the environmental device for temperature”” under “other” in the focuser control panel if you are using an autofocus such as the n-step focuser, even though Nstep has its own temperature probe. If you do, it will give you an error message when you launch the sequence as SGP will be expecting a weather station. There is little info with the error message that will help you troubleshoot that one. Jared was right in his above reply.
Problem solved.