Manual rotator and Frame Wizard

When using the Frame and mosaic Wizard everything works fine except I never get prompted to rotate the camera. After centering it says rotation error is n/a. I have to go to target settings and right click rotate and go through the rotation only centering routine to get an idea where my camera should be in coordination with the FMWizard. The documentation says I should be prompted but for me only when ran separate from centering.


It’s because you have not turned on automatic rotation in the target settings.

In Target settings under the sub heading ‘other’ I have rotation checked. The degrees are displayed correctly in what I have for FMWizard. I’m out imaging now just never got prompted. Unless I’m in the wrong menu?


You will not be prompted to rotate the camera if you are already within tolerance. Sounds like you ran it manually prior to starting the sequence. Is that what’s happening?

I ran it manually to start the sequence to get the framing I wanted, but I was 158 degrees off initially. The centering tolerance is set to 1 degree. I do hear a Windows ‘ding’ a few times during the centering and rotation routine. Is it possible there is an error somewhere? I don’t see any dialogs pop up.

You’ve lost me now… If you ran it initially and got the framing you wanted, why would you expect to be prompted again?

Not sure what this means. Maybe PHD2?

I don’t think so… lots of people using this, but who knows?

I only ran it manually after I was never prompted to rotate the camera to match what’s in FMWizard. I ran it 3 times before I did the manual rotation.


You can send logs while a sequence is running… it won’t hurt anything.

I don’t have the internet where I’m imaging and cell service is spotty. I will try and look through and send the logs tomorrow. Thanks for the quick responses.


Here is the log file. Note that this was my first time using SGP in the field so it’s probably operator error.

Just so I’m clear, when I start the sequence for the first time, it’s supposed to run through the centering and rotation routine correct?

In the log file, this took place from the beginning to about 1.5 hours after start up.

Thanks for your time

Solved. Well I started up again tonight and it did prompt to rotate and kept doing so until I was within tolerance. Thanks again


OK. Well, I took a look at your logs and you were not being prompted because you were already in tolerance.

You performed several centering actions (without rotation) and your camera was ~269 deg east of north.

[1/1/2016 7:59:53 PM] [DEBUG] [Telescope Thread] Syncing the rotator to 268.94 degrees…

Then at ~20:20, you started throwing rotation into the mix. You (your target) asked to rotate to 339 (159) degrees east of north.

[1/1/2016 8:20:23 PM] [DEBUG] [Telescope Thread] Performing auto center step 3 (rotator)…
[1/1/2016 8:20:23 PM] [DEBUG] [Telescope Thread] Moving rotator to 339.0…

You rotated your camera to achieve 339.14 degrees (within your specified tolerance).

[1/1/2016 8:24:34 PM] [DEBUG] [Telescope Thread] Syncing the rotator to 339.14 degrees…

After this, you were never prompted again because your camera was already in the correct position. Nothing looks amiss here…

Great, thanks for taking a look. Great support with this program. I was queing the centering task manually from the menu instead of letting SGP run things. Which it does wonderfully.