Meridian Flip failed - no hints in image and not triggering blind solve

Last night, I had a failed meridian flip. On further investigation, it turns out that SGPro didn’t provide any hints to Pinpoint and as a result, the plate solve (and meridian flip failed). I checked the plate solve image and sure enough, there aren’t any of the hints (RA, DEC, scale…) in it.
Furthermore on this fail, SGPro did not attempt to blind solve the image (which would have succeeded).

I have my log file here: (at 3:12, SGPro attempts the Meridian Flip and you can see that no hints are written to the image)

The plate solve image is here:

The night before it still worked and the only thing I changed in the Control Panel is the temperature compensation step size.

Any ideas are appreciated!


I think this might be a problem with the new version of SGPro. That was another change that I made yesterday (but completely forgot about).

The same thing happened tonight again (Meridian Flip failed in the same way as described before). Then I reverted to version (which was the version I was running before). Then I tried again and the Meridian Flip worked.

If you’re looking for the hints in the FITs file, you won’t find them there. For PinPoint we pass the hints via COM so we don’t need to put them in the file. However we should still be outputting them in the log so it’s odd that we’re not seeing them there.

We almost always test with Pinpoint as it has some other nice features we use when testing SGP, so I’m really surprised that if something was broke there that we missed it. However I’ll go through our tests again and see if I can uncover something.