Meridian Flip failed.....sort of

around 3:29:38 the Flip routine got stuck and , I guess, timed out and went into Recovery Mode …just wondering why this happened. Recovery mode worked, but it was something I had never run into before.

Hope I did this dropbox thing right …

Looks like the scope threw an exception during one of the slews:

[7/5/2016 3:34:50 AM] [DEBUG] [Telescope Thread] Telescope: Slewing to J2000 RA: -0.000349064842232849 (-00h00m01.26s) Dec: -0.0159240907803095 (-00°00'57.33")
[7/5/2016 3:34:50 AM] [DEBUG] [Telescope Thread] ASCOM Telescope: Error in Slew : SlewToCoordinates() A property value is out of range (System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Runtime.InteropServices.COMException: SlewToCoordinates() A property value is out of range
   --- End of inner exception stack trace ---

So it should. Negative right ascensions are not allowed, the range is between 0.00 and 23.999…

Could this be the result of a coordinate conversion from JNow where a small positive Ra is converted to a small negative Ra?


Ah, good catch. I didn’t see that. Although I’m not entirely sure where it’s getting those coordinates from. They seem pretty invalid and no where close to where they should be. Only thing I can think is that maybe I left some of the “offset slewing” behavior in 16 by accident. I can’t account how those coordinates would get set by any other means.

Can you give .17 a shot?


ummm…could you explain in Newbie talk ??? Did I do something wrong because last night the flip was really bizarre and will post the log in a bit.

around 1:09 am she would not run the flip routine even though the scope DID flip and then got all messed up with the centering routine even though it reported that the flip was not done…

Looks like a similar issue. Can you please try


I had a little trouble again last night . I will try .17 tonight . Thanks.

Well I got a chance to use the latest version of SGP The centering overall works much better. After the meridian flip it did work but it took 13 tries to get it to center. Do you have any idea why it took so many tries ??

Log …around 12:48:17 am the centering starts…

Wow, that is a lot of error…and then BAM, it magically works to within 10 pixels! I’m not really sure. I wonder if the mount was in a place that it couldn’t move? Like it was hitting some limits on one side of the meridian and couldn’t slew. However you’d expect to see the error move if that were the case. It seems pretty solid.

Unfortunately I don’t have a great explanation for why this happened. All I can tell you is we told the mount to slew to the same location multiple times and eventually it did. I don’t know why it stayed relatively stationary for so many other slews unless the model in the mount was telling it that it was on target.


thanks Jared, I will double check the limits I have set but I am pretty sure that is not the problem. I use a Bluetooth connection to communicate with the mount and I assume there is a delay . Do you think that has anything to do with it ??

I think that’s unlikely. I mean we are getting data to and from the scope or there would be lots of other errors in that log. So it seems like the communication is just fine. Have you tried not building a model on your mount? Just using a single star sync?


I have NO model on the mount. I just use the solve and sync with SGP , that seems to work just fine. Its after the flip centering that is hit and miss. I think I notice it has more trouble when the scope is pointing in the Southern sky after the Flip, if that makes a difference. But, like I said, the very latest version of SGP, the .17, seems better.

SGP does a Solve and Sync before and after a Flip …is that right ???

Well, maybe backlash or balance then? But that would have to be a TON of backlash or balance.

Nothing changed from .15 to .17 in terms of centering. .16 might have had a regression in it from a test change I was doing. I think that was accidentally released which could have caused issues, but I’m not 100% sure it actually got out into the wild.


ahhhh…could be a balance issue. It is a very portable setup .