Meridian Flip failed

2 Nights ago my setup was busy taking pictures of a 9 panel mosaic of the Heart Nebula. I went to bed during the night and the next day SGP had done a very good job. Not only had SGP changed panels during the night, but it also had done a successfull meridian flip at about 4 in the morning. Without changing settings I started SGP last night again, but this morning I found my telescope hitting the pier. It not only failed to do the meridian flip, but it als went way past the “stop sequence at 6.30”.

The log file can be found here:

Can someone tell me what went wrong with the meridian flip? I saw in the log file that there was no need for a meridian flip as the telescope was on the east side of the pier, while it was on the west side. I’m not sure where SGP gets this information from.

It gets it from the ASCOM driver for your telescope.

You meridian flip failed because your mount reported it was on the east side for the eintrety of the sequence. SGPro can’t so anything about this. You need to ensure, that before you leave your mount, the telescope is reporting it is on the correct side of the mount. We may add in a way to see this easily from SGPro (right now, you will need to check your mount’s driver).

Your target failed to stop at the end time because of a bug that has been addressed in 2.4.3.

[27/09/2015 02:17:19] [DEBUG] [Sequence Thread] Checking if Meridian Flip is needed
[27/09/2015 02:17:19] [DEBUG] [Sequence Thread] Meridian flip not needed, telescope on East side

1 Like

Thanks Ken for the explaination. I did some testing this evening with a target that was about to pass the meridian. EQMOD was displaying that the scope was on the west side of the pier and point east. The log file of SGP was also saying that there was a MF (Meridian Flip) coming up, bu that the target was nog yet on the west side of the meridian.

After passing the meridian SGP flipped the scope and all went well. So I went back to my original target I was also shooting the night SGP refused to flip the scope. This target (the Heart Nebula) was in the northeast and I noticed when the scope had slewed to this target that my counterweights were just on the west side of the pier (so just before the lowest point). In theory my scope is then also on the east side (opposite of the counterweights), which was true when looking at EQMOD, which said “pier side east, point west”. Starting SGP it would take only 15 minutes for the counterweights to pass the lowest point and after that EQMOD displayed “pier side west pointing east”. Because the sequence allready started before the counterweights th lowest point I checked the SGP log, but after every frame it still reported that a MF was not necessary because the scope was on the west side of the pier, while in fact it was on the east side.

Because I didn’t want to leave my setup runnng while a MF should take place in 4 hours and SGP still logged that a MF wasn’t necessary while “the scope was on the east side of the pier” I stopped SGP, disconnected all equipment after parking the scope, restarted the PC, started SGP again and opened the same sequence again. Now SGP is logging that it should do a MF, while the scope is on the west side of the pier, but that a MF wasn’t necessary because it was not on the meridian yet.

To make a long story short: it seems that SGP isn’t reading the status of EQMOD during a sequence, but only once in the beginning. If EQMOD reports at the start of the sequence that the scope is on the west side, it won’t do a MF for the whole duration of the sequence. Hope this info is usefull for the next update of SGP (which by the way is the best piece of software I ever purchased!)

1 Like

I’m still confused about an automated meridian flip in SGP. Last night the scope should perform a flip at 0.30 hours so I stayed up to watch this. And it did, but not without my intervention. After the last frame ended before the scope reached the meridian, SGP performed it’s task and solved the last frame, stopped the autoguider (PHD), flipped the scope and tried to center again. After that I got some kind of message that the difference between the reference frame and the last solved frame was too big. After clicking “ok” I re-centered manually and resumed the sequence. All went well for about 10 seconds. After that the guiding on the declination axes was not reversed, thuogh I put a mark in the checkbox of PHD that says "“reverse dec output after meridian flip”.

This is why I have 2 questions:

  • should I remove the mark in PHD because SGP is taking care of that (I remember there was an option in a previous version of SGP)?
  • normally when there is a large difference between the reference frame and the actual starfield, SGP could take care of that, no matter what.

A link to the log file can be foud here:


Please see this post for instructions on determining whether you need to check the “reverse dec output on meridian flip” option in PHD2.

Another thing that is important is to make sure you have PHD2 using an ASCOM connection to your mount. That means you should have Mount = your mount’s ASCOM driver (and not “On-camera”). If for some reason you must use On-camera, then select Aux mount = your mount’s ASCOM driver. Once you have an ASCOM connection to the mount in PHD2 then PHD2 will manage calibration flips automatically.


1 Like

Thanks a lot @Andy for your solution. I’m going to try this right away tonight.

Edit: tested PHD tonight: without the mark in the checkbox in PHD for reversing the dec guiding after the MF all went well. I’ve now set PHD to pulseguiding (no ST-4 but via EQMOD). Keep my fingers crossed!