Meridian flip failure - idiot seeks help

I hope this is the right part of the forum.

I have a CGX mount in a Pulsar observatory. I’ve tried various permutations to connect the ASCOM driver for the observatory dome to SGP, but the only method that has worked has been to choose ‘POTH hub’ for ‘telescope’ and then connect the POTH hub to both the scope and the dome, and then slave the dome to the scope.

So far, so good. But when a meridian flip is due, it fails to occur. This evening, I tried to do a manual flip to see if I could discover the problem. When connected via the POTH hub, SGP just froze when it came to slewing the scope, and had to be terminated. If I selected ‘Celestron scope driver’ instead of ‘POTH hub’ for the ‘telescope’ setting in the equipment list, I got the error message below.

I apologise in advance if other people have asked and an answer has been given, but I tried searching and couldn’t find a solution.


Please see here for instructions on how to get at the log and we’ll take a look.

Thank you Ken. I’ve uploaded two log files here - I hope they contain the information that you need.


In this case, you have encountered a timing bug that is fixed in the beta I am about to release today or tomorrow.