Meridian flip not working with SGC

Hi all
I’ve posted the recently but had problem loading the log and am not getting any replies and I may have not posted correctly so here it is again with a link to my log in DROPBOX
I’m unable to get the meridian flip to work at all with SGP
I get to the flip time and it starts to go through the Flip sequence. ie; STEP 1 - solve and sink, STEP 2 stop auto guide, STEP 3 Perform slew… then will not slew the telescope and come up with the message "ERROR - TELESCOPE FAILED TO PERFORM MERIDIAN FLIP:
I have tried everything I can think of to fix this, latest software install etc.
I have a Skywatcher EQ6 PRO running with SYNSCAN and ASCOM Drivers all the latest software installed.
Any help would be great

SGPro gave the command to your mount to flip, but it decided it didn’t need to do one. Are your lat / lon settings on the mount ASCOM driver correct?

You can also use the User Profile Manager to set the lat / lon for your mount.

The ascom driver does not have a Lon/Lat setting that I can see, I do have it set in the SGP profile manager.

I see SGP tried to flip and then stated that the mount was already on the west side of the pier, and yes, it was on the west side to start with and should have flipped to the East.

I did add the values to Ascom just now. Maybe this will help

Still unable to get meridian flip to work. Tried last night with the same results. Scope is on the west side of the mount and SCP will not slew and reported that it “failed to flip as starting pier side and ending pier side are the same!”

You will need to reproduce this issue (seems like it should be easy enough) with your mount’s ASCOM trace logs turned on. There are 2 general classifications of mounts… ones that we can ask to flip (explicitly) and ones we we need to perform an implicit flip. Yours is the latter. An implicit flip means that we just issue a slew command and hope that your mount thinks it’s time to flip. In your case, this is not happening. I see you are asking to flip 2.5 minutes past meridian which should be sufficient. Is there possibly a setting (in your driver) that will force the mount to flip if past meridian and on the wrong side?

I can not find any settings to force the mount to flip from the wrong side…I’m using Ascom drivers and Synscan pro directly to the mount

I had this same issue and it seems that it had to do with the settings in the mount not wanting to flip when SGP wanted it to. What is interesting is that for over a year I had the exact same settings and then it started doing this.
I ended up being more aggressive. I told the mount to wait only 1 minute after the meridian to want to flip but then I told SGP to flip at 5 minutes after the meridian. This way when SGP issued the “slew” for the flip the mount would say “oh crap, I am 4 minutes over due for a flip!” and then it would flip fine.

If you don’t have any setting you can change in your mount driver/ascom/hand controller/ etc, then you just have to make the time higher in SGP perhaps? Try going up a minute at a time and see if one works. This is something you can try any time of day if you turn off all necessities of plate solving. You can pick a target that is 20 minutes ahead of the meridian and then set up a sequence to take a bunch of 8 minute exposures and see if it flips. If it does not, set the SGP flip time to an additional minute. Try again and again.flip

Thanks for that I will give it a try and let you know how it works


This is the ASCOM driver setting I am referring to. Not sure what or where it is, but “I told the mount to wait only 1 minute after the meridian to want to flip” is what you need and then, as noted above, ensure SGPro’s setting is past that with a decent fudge factor.

Mine specifically is not in the ascom driver unfortunately but in the mount computer itself. I do have an option in the ascom to auto flip and the theory is you set the mount to auto flip and then figure out in SGP when to tell it to STOP taking photos and just wait. The the time is reached, the mount does its thing and eventually SGP figures out it is on the other side of pier or whatever it determines and then it resumes the sequence. I have not done it this way yet. This is specific to my 10Micron though. Not sure about the above poster’s issues or how to resolve them. Other than trial and error. Which is why a few weeks back I asked about how to get my system to operate without requiring a plate solve. Which you thankfully fixed for me. That made it easy to sit here indoors while watching Amazon Prime Video and test different settings.

Well I managed to get the meridian flip to work while taking shots of the Helix Nebula NGC7293 although I did encounter a major problem in so far as the mount slewed to the east and did a plate solve and lined up the nebula then it realised that the scope was 1h30 pasted the meridian so started to do a meridian flip but went the wrong direction and continued in the same direction doing almost a 360 and crashing all my equipment into the tripod legs…how do I stop this from happening again.

I’m not sure I am following entirely.

What does this mean? When you say “slewed to the east”, I am unsure if this means it flipped or just slewed on the same side. If it’s a slew, I am not sure why that would happen as the first mount movement of a flip should ALWAYS be the actual flip itself.

I don’t understand this. How did you get to 1.5 hrs past the meridian?

Not sure what this means. Do you mean that it had already flipped and flipped back or do you mean that the mount tried to flip by going “under” the tripod? If it’s the latter, it seems like maybe your mount thought it was on the wrong side of the pier.

If your driver supports it, I highly recommend enabling slew limits for equipment safety. If it doesn’t, it’s a great thing to ask for…

when I started the sequence the mount slewed to the east side of the mount to line up with the target and did the initial plate solve and lined up on the target…then in the telescope control module the time to pier flip showed - 1:30 time to meridian. then Started to do a pier flip. It when through the sequence Taking a plate solving photo,Plate solving,slewing etc, but instead of going back past the park position the scope whet in a 360 direction, ie: from east to south to west, not from east to north to west, (I’m in the southern Hem) and tied the cables around the mount until it got to the other side of the mount to line back up with the said target.

I’m unable to determine what is going on from the description. Can you share the logs? Have you made sure that your lat / lon in the ASCOM driver is accurate?

Look ken I will take a little video of what’s going on tonight and send you a Dropbox link I think that will be the easiest way to see what’s happening and I will also put the log there as well. But yes I started the sequence from the parked position and the mount moved to the east side of the tripod and pointed the telescope at the target. It then came up with the meridian position as -1.30 and then when through the motion of doing the meridian flip sequence, but instead of rotating back to the west side past the park position it rotated down underneath to the west side wrapping the cable around the mount

ok, will wait for further info… no need to go through the trouble of taking a video… logs really are just fine. We’ve read through thousands of them and can usually tell what is happening.

All good thanks :pray:

I hope this is the right log,

There is indeed flip attempt in that log… I’ll take a look through.