Meridian Flip Options - Bug in Beta 10?


In the “Meridian Flip Options” of the “Telescope” tab of “Equipment Profile” there’s a setting for “Degrees past Meridian to Flip”.

I want to use a value of -3. When I enter this value, SGP asks if I want to save the changed profile to which I respond “Yes”. However, when I go back into the “Meridian Flip Options” the setting has reverted to the default “0”.

This isn’t new to Beta 10, because I’ve noticed this several times previously but I’ve always put it down to user error. This morning, I’ve proved that it’s not.

I’m running Beta 9 on a Win 7 laptop.

Also, while writing, (and I apologise if this is being too pedantic); the Telescope tab actually refers to settings of which the majority relate to the Mount - not the Telescope.

Keep up the great work


1 Like


This is because your mount does not support flips prior to crossing the meridian. While we cannot change that, we have made the user feedback, in these cases, much more clear.

In the world of ASCOM telescope and mount are synonymous.

Thanks for the report.

Thanks for the feedback Ken.

I have a 10 Micron GM1000HPS which does support meridian flips before and after the meridian.

This is set using the mounts “Flip Slew Tol” setting which I have set to 10degrees.

I’ve asked a the author of the 10 Micron driver that I use about this and his response is:

"… The ASCOM standard uses the pier side property in conjunction with destination side of pier. The mount needs to be set to allow this by adjusting the hand-set parameter “Flip Slew Tolerance”. If you set it to, say, 15 degrees, the mount will allow a forced flip commanded from the application if the target is within 15 degrees of the meridian. The procedure is to set the “destinationSideofPier” property and then command the slew. If the application doesn’t set the property before issuing the slew, the mount will not flip and you will be left with whatever tracking time you have left to the “Flip Guide Tolerance” hand-set parameter.

If you use my driver the application should detect that the mount is capable of pre-meridian forced flipping…".

Any further help you can give on this subject would be appreciated please.

All the best


The description of what the ASCOM standard specifies doesn’t seem correct to me.

PierSide scope.DestinationSideOfPier(ra, dec)
is a method that returns the pier side that a slew to the specified ra and dec will end up at. It doesn’t set anything, or do any move.
If a mount can set the side of pier then scope.CanSetPierSide will return true and
scope.SideOfPier = requested side of pier
will do a slew to get the OTA to the other side of the mount. If the mount can’t reach the current position on the specified side of the pier it throws an exception. If it’s already there it should do nothing.

This will need a SGP log and a mount driver log if possible to see what is going on. I suspect that, from what Ken said, the mount driver is reporting CanSetSideOfPier as false, this will cause SGP to believe that the mount can only slew to the other pier side after it has past the meridian.


Hello steve, what 10µ driver do you use ? 10µ official or per frejvall one ?

Hi - thanks Chris and fdx.

I’m using Per’s driver, but the same thing WAS happening with both this and the 10u driver.

I’ve solved the problem this evening - I have been trying to change the Meridian Flip setting in the Equipment Profile without the mount connected and SGPro hasn’t been saving the Degrees past Meridian to Flip setting.

Tonight, I installed Beta 11 on my Observatory PC remotely using Team Viewer and tried changing the setting again …and it didn’t save. I then went out to the observatory and powered up and connected the mount. I then tried the setting change again - and it saved - several times - correctly…and it now saves the setting correctly without the mount connected.

Beats me what’s going on! Heyo - at least it’s now working - thanks for your help everyone.


Nice, you should post this workaround on the 10 micron forum, and communicate this to 10 micron as well…
By the way, do you now do your guider calibration far from the pole ??? :wink:



As mentioned in the Beta 11 release notes, we’ve made this a bit friendlier. Now, the sequence, when the mount is not connected, will allow you to set this to whatever you desire. Upon connecting SGPro will query the mount to see if this parameter is acceptable if it is not, the sequence will balk and reset it to 0. If the mount allows it, you won’t see anything and the value will be accepted.