Minor Mark as Bad bug

I noticed while trying to mark a frame as bad, I got a dialog saying there was an error marking the frame as bad (right click on image, select mark as bad), specifically index out of range error (I don’t remember the exact text of the message). Clicked ok.

When I tried to mark it as bad again I got a file not found error. Upon opening the output folder, the file was renamed as bad.

Didn’t see anything obvious in the log but this was around 1:25am (give or take 10 or so min). Attached.

sg_logfile_20150801193036-copy.zip (44.9 KB)

Which image were you marking as bad?


Or frame 8?

Actually frame 7 so the one you cut/paste, and then later in the night frame 13 (not in the log). Same thing happened with frame 13 (renamed ok, same errors).

I’m not sure if the total number of frames is supposed to increase as the result of marking one bad (behind on reading up on these features), but it didn’t in either case.

Thanks for the help,

OK. Well I am out of ideas… I have tried several things to try and reproduce this issue, but I cannot. Everything I try works fine. I even reproduced your attempt to create the world’s longest file name.

The total number of frames to capture should stay the same. The number you have captured should decrement by 1 (assuming you have the dialog box checked).

If you get a chance can you grab the exact text of the index out of range error?

Zing! Well, better than just “c:\image1.fit” … :smile:

Here’s a screenshot of the error (note, I was right clicking and selecting mark as bad, not clicking the red x.) Also, which dialog box should I have checked?

Right, I caught that and I was using this method as well.

Not sure what this means.

Thanks for the SS. I’ll see if I can trace that back. Are you able to reproduce this on demand? If so, I can add more granular logging.

This is what I was asking about – I wasn’t sure if you meant something other then selecting “mark as bad” by right clicking. (An option somewhere to auto-decrement?)

I originally had 15 frames set, and I ended up getting 15 including the bad ones.

I can repro the problem however to get the screenshot above I loaded the sequence, then loaded the image, and selected mark as bad. So, the sequence wasn’t running. Not sure if that invalidates the test, but nevertheless, it’s the same error I saw while the sequence was running.

Can you send your sgf file please?

@Bhwolf Thanks for the sgf. I was able to trace the error to targets having the same name. SGPro was expecting target names to be unique, but was never enforcing it. The next beta will enforce this naming behavior.

Ah yeah, that makes sense. I duplicated two entries to test centering with different solvers/tinkering but wanted to keep the names the same (no big deal). This also might explain why SGP complained when starting the sequence that coordinates were entered but no centering option selected – I double checked and couldn’t figure out why it was telling me that, and I think it was looking at the other target.