Moonlite Nightcrawler position

Not sure where to post this but I have am having issues with displaying the current position of a new Moonlite Nightcrawler. I am getting “NaN” with a little degree symbol under Current position. It will connect and rotate, one direction no matter if I reverse directions or not, but can’t figure out why it will not display the position. Any suggestions?


Seems a bit odd. Does it show the correct position in the stand alone app for the nitecrawler?
I the position displayed on the nitecrawler screen?

If so, I would try reloading the ascom driver, or do a cable check ??
Focus or Rot position? or both?


I also use a NiteCrawler and have no issues with rotator position reporting in SGP. I’m using a refractor, so once I got the direction reversed it has worked flawlessly.

What happens if you use the NiteCrawler software to control the rotator, do you see the rotator position?

SGP Devs- It might be worth having a “telescope type”, refractor, reflector, cat, etc., and auto-set the rotator direction with respect to the image orientation.

Late reply. I have tried everything suggested with no luck. It works fine with the SkyX and with the NiteCrawler software. I am using an ES 127mm refractor and have tried reversing directions but no luck. I am sure I will get it figured out, probably something simple.

I have not seen that issue with my NiteCrawler. Have you tried updating your ASCOM drivers and NiteCrawler drivers?



I tried that also.

If you are still having problems, let me know and we can setup a Skype session to resolve this in real time. I can bring up my system and go over all the settings and such.


May help to post a log too. Also if you use something like POTH or another application with the ASCOM driver does it seem to work?



Sorry that this has taken so long. I tried to get the Nightcrawler Rotator to work again today and have a log attached. I am still getting NaN for the rotator position when it connects and have tried everything I possibly can to get it to work. If I try to move the rotator it just keeps moving in one direction and never stops.

ASCOM.NiteCrawler.0115.002160.txt (10.7 KB)

Ok, finally figured this out. The issue is not with SGP. I have a WR25 and one full rotation is 505,690 units. Those are the units for a WR35. I should be getting 374,920 units per 360 degrees with a WR25. Ron at Moonlite is great so I am sure it will be rectified in no time.

Fixed in about 30 seconds after receiving a code to reset the controller to a W25 from Moonlite in their native program.

I am confused. Did Ron issue new drivers or is there a code I can get? I have a both a NiteCrawler W35 and a LiteCrawler which is the equivalent of the W25 which may be affected.

In the Moonlite Nightcrawler utility program under the configuration tab there is a blank box Ron had me put a code in and click send to reset the unit. This sent a command to the controller to set it to a W25.

Thanks. Can you share that code? If not I will just contact Ron if I have the issue.

What he sent me was a one time use.