Moonlite rotator

Hi all,

I need help with connecting Moonlite rotator to SGP. I have no problems connecting just the focuser via mini V2 controller, but when I switch to dual controller SGP does not want to connect to the focuser + rotator. I have installed rotator as a second motor in ASCOM driver (from Moonlite website).
The combo (focuser+rotator) works with non-ASCOM software from Moonlite website. Any advice will be valued and appreciated.


I am not sure if this advice… We will support rotators and focusers if they each expose their own ascom driver (despite) being connected. I don’t know what a dual controller means. What does SGPro tell you when when you just connect the rotator from the list of rotators (without connecting the focuser)?

The Moonlite dual controller has two motor drivers in one box, controlled through one USB connection.

The current ASCOM driver should be fine with this and should be able to be set up to control a focuser and a rotator.

There’s not much I can say without some data, such as logs, but the focuser and rotator must both be connected using the current driver. Using an old driver for the focuser will stop the rotator connecting.


Thank you Ken and Chris for you replies.

I am using the driver provided on Moonlite website for focuser and rotator - am I right assuming this is the latest one?

This is what I have done- hopefully it will help in identifying the issue:

I reinstalled ASCOM, selected rotator as a second motor.

Then when setting up with SGP, it won’t connect at all. (The same USB port, and it works with non-ASCOM software). I keep getting this message: Error connecting to Moonlite DRO Focuser Drive.

When in SGP I selected focuser as motor 2 and rotator as motor 1 (it is physically the other way around) in ASCOM window, SGP connected to the focuser/rotator, but of course instead of focusing it rotated the camera.

Thank you

I’ve provided some more suggestions when I replied to the email that Ron forwarded to me, basically check that you are using the correct driver. “The Latest” tells me nothing. Also collect some logs. We need to find out what is happening.

I tried it for myself and with my DRO hardware and what I think is the latest driver and it is fine, I can connect to both a focuser and rotator and control both. My version of the latest driver is 6.2.5270.20609.

It’s not really a SGP problem so probably better doing it off this list.


Thank you Chris for your quick reply. It looks like Moonlite website allows only for downloading the older version of the driver 6.1.0. In case other users might need it too, would you be able to let me know where can the 6.2 version of the driver be found?

Thank you

I’ve just downloaded and tried the 6.1 version from the MoonLite web site and it is fine. I can connect and run both a rotator and focuser at the same time.

The change was only because the rotator size defaulted to 2". It looks as if it never found it’s way to the web site.

I need to let Ron know but that isn’t the reason for your problem.


@Suavi just to be clear, you know you need to connect to your combo device like it is 2 separate devices right? Find your focuser, click connect, go down to the rotators, find your rotator and click connect there too. It sounds like you might just be connecting the focuser and expecting the rotator to connect as a result of that. Maybe I’m wrong…

Dear Ken and Chris,

I managed to connect the rotator and focuser to SGP- it works like a charm.

It happened to be operator’s mistake/lack of experience - I was not connecting the rotator in the SGP, but only the focuser…

Sincerest thank you for your patience and help.



Hang in there! The configuration of SGP and the Moonlite focuser/rotator combination does indeed work, and I use it myself.

In the past there was a bit of confusion about downloads, particularly making sure to get the proper ASCOM stuff from Moonlite, and once or twice older versions of the software were on the website than what was actually available.

Although you probably don’t need it during your actual imaging, you might try running the ASCOM POTH utility, and connecting that to the focuser/rotator combination first, and verifying that it works.

Going through POTH will at least get the ASCOM chooser open so you can select the COM ports where your focuser and rotator are appearing, and choose your rotator size, etc. Making sure you’ve identified which COM ports the Moonlite has landed on is important. Digging around the Windows registry may help clarify this. Also be warned that sometimes the COM port names will change. I had this happen during an automatic Windows update and it took a bit of fussing around to debug.

I’m not at the imaging computer now, but could likely find some time over the weekend to walk through things with you and we could compare notes on how each of our systems is set up to try to figure out what yours is still troubled…


Hi Jerry,

Thank you for your kind offer,

I managed to correct my mistake and all is working as it should.