Need help with sBig filter wheel settings and AF not responding to changes on sBig ST camera USB

So I DL’d and began to work with this software as my main control program, so far I’ve had a blast, it’s really well done. I have had a lot of issues, but instead of complaining and posting I went through each one methodically each night, 1 problem at a time and all of them I have been able to figure out, from plate solving to auto focusing. So far so good. except for one big issue that is driving me nuts.

My current set up:
Losmandy GM8 gemini 1 (latest ROM) serial com 3
sBig ST-2000XM w/ CF8 attached, using internal guide chip USB connection
Takahashi FSQ-106n w/robo focuser attached (serial com 4).

I have selected the correct CFW in the equipment panel, double and tripled checked it, have all the filters in the correct spots, even disassembled the CFW and had some out of place, fixed that the current order is:
1-Lum
2-Red
3-Green
4-Blue
5-Ha

They are set in the filter set up naming list with close focuser numbers applied as well. Checkmarks checked.

They never show up in the filter notice or panel, it always says N/A yet I can see and select them via the pop up menu for filter wheel I can hit the set the wheel moves them, I have verified the correct filters are in place as I select. Display still says N/A.

When shooting sequences the filter wheel moves correctly (I assume) but it doesn’t seem to register filter panel still says N/A. I have tried selecting and running both auto select and the correct CFW8 in the equipment set-up. Double checked the profile is saved and control panel is set correctly too after connecting. The log seems to show the filters as only numerical numbers, though the FITS headers written will have the correct filter color applied to the image header - strange.

Now when autofocus is to occur, it focuses every single frame (huge time waster) or I can select AF via number of frames say every 4 frames (depending on how many frames I set up in the sequence for each filter), it works but not directly after the CFW changes. It is always off by 1 frame so frame one focus shoots then 2, 3 & 4 shoots, then filter wheel changes frame 5 shoots then the auto focus starts leaving the first shot with the new filter to be out of focus (still on the previous filter focus setting). the rest are fine, this continues. The filter is never shown by color or name, always N/A.

I see a similar issue Filter Wheel Problem SBIG but his filterwheel was at least responding to the color selected, and showing up in the filter wheel panel window.

I’ve included my log file and sgp file from my last run. I also sometimes have issues connecting to PHD2 at start up but that is solved by me manually running the guider first. not a big deal, I’ll figure that one out I’m sure it 's me and not the program.

If I can get the filter wheel running correctly then I’m most definitely purchasing SGP. Thanks it’s been a fun test so far, with some incredible software you have created.

Also wanted to let you know I also have PemPro v3 and it runs fine through PHD2 (PP edition and the SGP drivers). Just ran that the other night successfully for several hours on my mount.

Rain has set in this week in Texas so probably not until next week to get out try anything.

LOG https://www.dropbox.com/s/40ib0ec6o385n5n/sg_logfile_20190916214940.txt?dl=0
sgf file https://www.dropbox.com/s/p1c83a7wv2825hk/M27.sgf?dl=0

Hope I got the correct log I saw two different ones close to the time I was shooting. If it’s not let me know and I’ll get the other one posted as well.

Sincerely,
Chriss - still testing SGP!

Any thoughts on this yet? I think tomorrow (Wed & Thursday) might have clear skies and a bit darker for some more testing. Hope I can get a reply soon, would really like to figure out why my filterwheel isn’t coming up correctly.

Chriss

To try and isolate the issue - does your setup work correctly with the ASCOM filter wheel simulator? It is going to be difficult for the developers to help if it is a driver or hardware issue.

In respect to PHD2 - my advice is to independently calibrate PHD2 at low DEC and set up a profile, keeping the calibration (assuming you have a reproducible installation). In SGP control panel, in the guider settings, select the PHD2 profile you saved and let SGP manage PHD2. Do not fire up PHD2 independently but let SGP load it up, guide, pause and so forth. I have difficulty when I interfere with PHD2, as SGP does not necessarily pick up on the status change and can get confused. I have hundreds of unattended hours to back up my advice.

@skyshooter

Well… it looks like the latest SBIG driver is either broken or it has changed out from underneath us. I have verified that the SBIG driver, while it is properly moving the CFW, is always reporting “None” for the current position… That’s unfortunate. I will reach out to SBIG, but I am not sure if anything will come of it.

@skyshooter Upon further inspection, it seems this behavior is reproducible by having the wrong CFW selected in the SBIG CFW options dialog. I have confirmed that choosing a CFW like CFW8 creates the broken behavior while “auto select” produces the correct behavior. You say you’ve tried this… unfortunately, I dont have any other insight other than to say, SBIG is returning “unknown” as the current filter.

Yes thank you. I will try again the auto select filter wheel" In the past the filter wheel panel still shows N/A very frustrating that sBig has broken the driver, it still works though in the very old software from sBig CCDops, I’d love to try to use CCDSoft v5 to check, but Software Bisque now requires me to purchase Sky X even though I’ve been a registered user in the past - I no longer have the CD or software despite owning multiple sBig cameras. My last demo run with Maxim DL v6 also worked fine, but no way am I spending $600+ for software just to use running my camera, especially when much better options like SGP exist! I plan to try my Canon cameras as soon as the weather clears maybe later this week.

Hopefully sBig will acknowledge the break in the driver and get it fixed, but with older cameras I’d tend to believe they just want us to buy new cameras instead, which I plan too - this time it won’t be another sBig (I’ve owned 4 previous models and still have 2).

Thank you for getting back to me on this, let’s cross our fingers they admit the problem as well and actually do something to fix it.

Chriss

@skyshooter

I don’t have any direct experience, but I think APT has recently added SBIG support (if you want to check with different software). https://ideiki.com/astro/Default.aspx

Thank you Ken! It’s not often a software developer will send a potential customer to another product. I will DL’d and try the program you suggested. However SGP looks much more polished and I will consider still purchasing a copy of my own to support you guys. Thanks again and still keeping my fingers crossed sBig come through with better updates drivers that work with SGP.

Sincerely,

Chriss

Ken, I was able to get out last night (I’m North of you guys in Plano). I did try the APT software and it handled the sBig camera and filter wheel very well, everything worked as it should, the software itself is very difficult I found, couldn’t make it connect to PHD2 nor was it easy to get other items working, mostly due to their inferior UI. SGP is tops here with ACP (aliebit a lot more expensive) I’ve done work with Bob the creator of ASCOM and ACP in the past, great guy.

I have another issue popping up which I’ll address in a new thread for others regarding ASCOM SGP API Camera calls.

Thanks again, I will be sending in some $$ to purchase your software at next pay period.

Sincerely,
Chriss