Need to identify proper ASCOM driver for SW AZ-EQ6 mount

I’m new to Sequence Generator Pro. What is the correct ASCOM driver that I should use to connect SGP to my SW AZ-EQ6 GT mount and where do I find it? Any help would be much appreciated.

I have used the az-eq6 for quite a while now and have always connected to it via eqmod/eqascom and select the HEQ5/NEQ6 option to connect. Has worked flawlessly like this. I have only recently started using SGPro but connect using eqmod

Thanks Julian. I’ll give that a try.

Perhaps this is not the place to ask this question but maybe I can give it a try?

I downloaded EQMOD/EQASCOM but have come up against a stumbling block. My SW AZ-EQ6 GT is linked to the controlling laptop by a serial cable leading from the SynScan handbox to an Aten serial-to-USB converter and thence into a USB port which my Device Manager tells me is using COM18. But in the EQMOD ASCOM SETUP window the listed available COM ports only go up to COM16. The result is that EQASCOM is not currently “seeing” the mount and I cannot control the mount from it.

I have had no difficulty in the past linking SkyTools3 to the mount using the same cable link and ASCOM with a Celestron driver. Unfortunately that arrangement only partially works for SGP in that although I can connect SGP to the mount when I try to slew the mount using the EWNS buttons the mount slews OK but then stops tracking so that my stars become EW streaks. It was this that prompted me to ask the suitable driver question in the first place.

I admit to being a bit of a dunce when it comes to hardware/software connectivity so any help that you can offer will be gratefully received.

That sounds like a deficiency of EQMOD. It should be able to enumerate the available COM ports, including those greater than COM16. You should report the problem to the EQMOD developers so they can fix it.

In the meantime, there is a workaround. You can remove some of the stale unused ports below COM16 and reassign your Aten converter to use a low numbered port. Here’s a description and instructions:


I’ll try the workaround and report back. Thanks Andy.

I’ll also contact EQMOD developers - it may help someone else later down the track.

Well I tried the workaround but only with limited success. I followed the posted instructions to the letter but the Device Manager did not display any more COM ports that it did before. So at that stage I was unable to identify which lower number ports may have been unused and/or could be freed up. However, I went on to stage 2 and examined the advanced properties for the Aten item in port COM18. It appeared that all ports from 3 to 18 were in use (although for what purpose I couldn’t tell) but ports COM1 and COM 2 were unused. Taking a deep breath I reassigned the Aten device from COM18 to COM2 and hoped that I wasn’t going to crash everything. After rebooting I opened SkyTools3 and after reassigning its telescope link to COM2 via ASCOM all was well and I could use SkyTools3 to slew to a target as before. So thinking that the problem had been solved I opened EQMOD/EQASCOM and made sure that EQMOD ASCOM SETUP was set to COM2 before opening the EQMOD HEQ5/6 window. But there it failed. After spending some
time trying to connect the window opened but only to say “Connect Error Timeout”.

So close but so far! If any ideas spring to mind I’d sure be glad to learn of them.

Hi Dave I think this is an eqmod problem and suggest joining the eqmod yahoo group where you will get more help.
The fact that you have connected to the scope and performed a slew shows that skytools at least can connect.
Have you gone through the eqascom diagnostics to check it is connecting ok?

Julian. I have posted a question on the eqmod yahoo group as you suggested and if and when I get a solution to the problem I’ll post that here to complete this thread.

In the meantime the following screenshot shows that when running Ascom Diagnostics and selecting the EQMOD telescope, after clicking the Connect button Diagnostics reports the telescope as being “Connected OK” but the EQMOD HEQ5/6 window still reports “Connect Error - Timeout”.

A bit of a puzzle!

Dave sorry to hear you are still having problems, at least you can test this in the daylight. I think there are issues with com ports with eqmod, have you tried using a different com port you could set it to com port 3 and see if it connects - I don’t think eqmod likes using higher than 9 for some reason, but I am not an expert. Lets see what eqmod group come back with. Out of interest what chipset does the aten ubs to serial adaptor use - some people say FTDI is better than the prolific one but I can use either.

I will look out for your issue on the group


Just an update to this thread.

Am still struggling to get EQASCOM up and running despite some substantial help on the ASCOM forum. However, I did discover that an option when using ASCOM with the Celestron mount driver is to hide or display a small window called HC Buttons that shows the four NSEW nudge buttons. This window was previously hidden but is now revealed automatically on connecting SGP to the mount. And if I use the buttons in that small window rather than the equivalent ones in SGP I don’t get the stop-tracking problem. An untidy solution but it does now let me use SGP to control the mount. I’d still like to be able to use EQASCOM so I’ll keep trying to find a way. In the meantime …

During the course of my investigations I came across an interesting quirk. Because one night it was convenient to use the Moon to prove that the NSEW buttons in the small HC Buttons window do not stop the mount from continuing to track, I had set my mount’s tracking rate to Lunar. But I noticed that immediately after using one or other of the NSEW buttons the tracking rate was changed to Sidereal and I had to manually reset it back to Lunar by using the mount’s hand controller. Of course most imaging will be done when the tracking rate is set to Sidereal and this small problem is never likely to be encountered in practice. Nevertheless, if the SGP boffins have nothing better to do they might be interested in having a look at this small bug.


As you have seen the Celestron driver mostly works with the Synta mounts, but I’m not able to support it officially. There are too many subtle variations and I can’t get the information I need to do anything.

It’s good to hear that the small pop up window works. That’s part of the driver and uses commands that are the same as the ones the HC buttons send.

The problem with the move buttons in SGP reverting to sidereal is because the lunar rate was set through the HC, not through the driver.

When you release a move button SGP sends a MoveAxis command with a rate of zero and an AbortSlew command (better to be safe). One of the things that is done is to set the tracking rate to the current rate and, because it was not set through the driver, this defaults to sidereal. If the rate had been set to lunar through the driver it should set the rate to lunar.

I can’t read the rate from the HC, there’s no command to do this.

Thanks Chris for your clear and very reasonable explanation.