Newbie and Wifi Scope

Hi everyone…newbie attempting to follow some basic instructions regarding Wifi Scope. Got the software running fine on a Windows 10 PC talking to my CGEM via a serial cable with USB adapter, but a bit puzzled now. SkySafari Pro is set up on an iPad. The instructions on the software landing page says “connect SkySafari to Wifi Scope…” I’m not clear on what this means, exactly? How do I make this “connection” exactly?

Steep learning curve here :slight_smile:

Thanks everyone…

Paul

1 Like

In Sky Safari, select LX200 Classic. Then, Go back to the main Settings page and click it again, it’ll have an option to put in an IP address and change it to a german equatorial. Make sure the ports match.

Good luck :slight_smile:

The WiFi Scope download should have come with a PDF detailing the setup steps. Was that missing or did you have questions on that process?

Thanks,
Jared

The pdf document explains thoroughly how to set up the software (both SkySafari and the WifiScope pieces) but doesn’t say a thing about how to actually make the connection between the laptop, iOS device and the mount. I have the serial cable attached to the mount, and it’s talking to WiFi Scope just fine…when I select “connect” on the Skysafari app, I’m greeted with a warning message that I need to check that I’ve turned on the SkyFi device in order to connect wirelessly to it. I know I must be missing something obvious…

The landing page says… …"Simply connect your scope to WiFi Scope and then connect SkySafari to WiFi Scope and enjoy awesome telescope control right in the palm of your hand…literally!

Bottom line, how do I make the connection happen (after setup is done…?)

Another way to phrase the question - is there a hardwire connection between the iOS device and the laptop running Wifi Scope? If not, how is the iPad (which is running SkySafari Pro) talking to Wifi Scope on the Windows laptop?

OK, figured that out…everything needs to be on the same wifi network (SSID.) So now I have a good connection between devices, but now my Celestron CGEM mount is non-responsive to input from SkySafari Pro. Ascom driver is installed and working fine (PHD 2 is working fine over the serial connection.) Multiple reboots of everything, no change.

Any help greatly appreciated!

Is your mount tracking or is it parked? I can’t recall if SkySafari or WiFi Scope will attempt to unpark the mount. If you move your mount using the hand controller does SkySafari reflect the position?

If you can also send the logs that will be in your “Documents” folder that would be helpful.

Thanks,
Jared

Well…after shutting everything down and walking away for a bit…restarting, it’s working fine now…crazy!

Thanks again for paying attention… :slight_smile:

I’m having an issue connecting to WifiScope with my iPad and SkySafari Pro…

I have a dedicated PC at my mount (running Windows 7), and it’s on a wired LAN connection to my router in the house. Is it possible to connect to WifiScope via wireless with my iPad? They’re on the same network. I’ve tried creating a ‘bridge’ on the mount PC between the wired and wireless adapters but that didn’t work. Any solutions for this? I’m sure there must be others with wired/wireless combinations on their home networks.

Thanks!

Yes, as long as they’re on the same subnet (likely the case) everything should be just fine.

There is no need to do this. Just make sure that WiFiScope is listening on the Wired connection. If WiFiScope detects multiple devices the “IP Addr” drop down will be active. Ideally you probably want to disable the wifi device in your network settings if you don’t use it.

Wired -> wireless works just fine. That’s pretty much the only way I ever use WiFiScope.

Thanks,
Jared

Jared,

Thanks for your reply! I experimented a little more last night (though it was raining) so I wasn’t able to power on my mount. I was able to connect when I selected a different mount - I am using an Orion Atlas Pro with EQMOD, and the Shoestring EQDirect cable (USB to RJ45) - when I changed the scope type in SkySafari to the “Meade LX-200 GPS” it successfully connected. While I was searching around for others who have a wired/wireless setup, someone online had mentioned using EQMOD and setting their scope type to the Meade LX.

Will this option be fully functional with EQMOD and the Atlas mount? That seems to be what was preventing SkySafari from connecting to WifiScope.

Thanks!
Tim

As a follow up - I have had some success when I set the mount type to “Meade LX-200 GPS” but I am still wondering if that is the best solution here? I am using EQMOD with an Orion Atlas Pro mount - selecting that mount in SkySafari doesn’t work…

Is the Meade option an acceptable workaround?

i don’t think it’s a workaround, my understanding is that WiFiScope implements the meade LX-200 serial command set. those commands get translated to ASCOM calls to whatever mount driver you happen to be using.

Correct. Wifi Scope implements the LX-200 protocol for SkySafari to talk to. It is not a direct “pass through” from SkySafari to your scope.

However all basic functionality should fully work.

I’m guessing you didn’t see the instructions for WiFiScope as this is covered there?

Thanks,
Jared

Jared,

No I missed that in the instructions I looked through for WifiScope setup. I recognize now the error I was receiving in SkySafari was both for network connection issues and mount types - but I assumed the former first! I saw on another forum a post about EQMOD and the LX-200 option.

I’m just happy it’s working now!

Hi,

Is it possible to control a Software Bisque mount using WIFI Scope and The SkyX?

Thanks,

Bruce

Yes, just need to ASCOM driver for TheSkyX.

Thanks
Jared

Hi Jared, new user here.

Things are running well with POTH simulated mount. However when I connect POTH to my ascom driver for my mount (its an ES EXOS2-GT) things go off the rails when SkySafari sends the :RC# command (that is what is reflected in the WiFi Scope traffic window. I presume this gets translated in WiFiScope into some generic request for information and passed on through POTH to the ASCOM driver…which does not in this case responde. It does respond to other commands, as read from the traffic monitor, specifically :GR# as well as the :St and :Sg for site lat and lon I guess. So my question is what is the :R# looking for from the driver. I want to pass along ASCOM request that is failing to ES to try and get the driver fixed.

Wes.

RC# sets the slew speed to Centering. Documentation for the LX200 Commands can be found here:

It may be that your mount doesn’t support that. But WiFi Scope should be querying if the mount supports it or not. I’ll have to double check that.

Thanks,
Jared

Thanks JAred:

I just saw the command, and in fact I can see the the traffic monitor says “Nothing” which is i guess what got returned…documentation is unclear to me rather it means the word nothing or just nothing came back. HaHa. ES says the driver fully passed ASCOM compliance testing…suppose that means all valid ascoms should be supported. What is the specific ASCOM command that is sent off to POTH so I can ask ES that question.
Wes