Nikon D500 Frame and Focus Image Download hangs

I am attempting to connect my Nikon D500 to SGP and, though it appears to connect in the settings dialog box (the icon turns orange), when I attempt to “Take One” on the “Frame and Focus” pane it displays in the status that the image was captured but then it hangs on the downloading step. I’ve tried removing all equipment except for the Nikon D500 and am connecting from the camera directly to the usb port on the laptop (it is the only usb item plugged in, no extension cables). Looking at the logs, it seems that the shutter speed might be getting determined incorrectly and causing a failure? I’ve tried shutter speeds of both 2 and 1 seconds and I believe the log is saying that the closest shutter speed supported by the camera is 0 sec and it is throwing an error. Is this something you are aware of and/or have recommendations to fix?
My log file and a screen capture of my settings are attached.
sg_logfile_20190923200443.txt (60.5 KB)

Testing with my D5100 and there certainly seems to be something going on with the Nikon implementation. I’ll have to dig in a little more but hopefully can address this soon.


Ah, I think I see the issue:

[09/23/19 20:05:17.901][DEBUG] [NikonScheduler callback thread] Capability                                        	Get	Array	Set
[09/23/19 20:05:17.901][DEBUG] [NikonScheduler callback thread] Shutter Speed                                     	1	1	0

Basically the “set” value for the Shutter Speed isn’t enabled. This generally means that the camera is not in manual mode or wasn’t in manual mode when connected to SGP. Disconnect SGP, place the camera in manual and reconnect. I think that should resolve the issue with capture. If you continue having issues let us know.


I believe this is resolved now.

In addition to putting the camera into Manual mode, I also had to turn off the “Auto-ISO Sensitivity Control” setting in the “Photo Shooting” Nikon menu. If I did not do both of these things SGP would exit the application and the camera would show an error until I removed its battery, waited a bit, then re-inserted the battery, turned on the camera, and pressed the shutter. It might help future users to add these details to the SGP help file; it seems obvious to me now but wasn’t at the time.

Thank you very much for responding and tracking down the answer so quickly!

Agreed, I’ll also see if we can detect these cases on connect and warn the user.


I just discovered another small detail: The camera cannot be set to take bracketed exposures otherwise it exhibits similar behavior. So the camera must be set to manual mode with automatic ISO turned off and exposure bracketing turned off.

@ihit140d Thx. I’ll add this to the Nikon section in our help docs