Nikon D7100 fails to connect

I bought SGP a few years ago and have kept up with the updates. I use a Nikon D7100 camera. I know that it used to connect to SGP. My main astronomy effort over the past few years has been visual, but I am now getting back into astrophotography. I can no longer connect my Nikon D7100 using the latest SGP. I know the Nikon is connected to the computer using the USB interface since I can see its icon. I remove both SD cards, set the Nikon to manual mode and manual focus, however when I try to select the Nikon D7100 the green Nikon light does not flash (indicating it is interfacing to something). When I try to take a picture SGP crashes. I tried looking at the help files and going through your forum but have not been able to solve the problem. I even tried uninstalling and reinstalling.


Please try the 2.4.3 beta. In the Nikon options you will find anew one called “Always use bulb mode”. Check that and give it another try.


Thanks for your reply.

I tried the 2.4.3 version, and checked the ‘use bulb only’. I was able to connect to my D7100 and take several test pictures. I have cycled the connection several times and took several series of test pictures with no problems.

Looks like this version works well with Nikon D7100.

Thanks for your help,