Nikon D800 connectivity

Hi all - I seem to recall another D800 owner having some issues connecting his camera but can’t find any of thsoe messages.
I’ve just tried connecting the D800 to SGPro, and although it connects fine, and everything seems to be happy, when I try to take either a framing and focus image or even run a simple sequence, the camera does nothing and eventually SGPro crashes.
Steps I took

  1. removed cards from camera
  2. plugged in and turned on
  3. selected D800 from the list of cameras
  4. connected and selected ‘fits’ format.
    at this stage if I hit the ‘take one’ there is no sound from the camera, but the sofware reposrts that it is downloading an image, but eventually SGPro hangs.
    Alternatively, I set up a sequence to take one frame, hit start, and the same thing happens.
    I use Nikon’s capture pro2 on this laptop fine, so I don’t think its a hardware issue, but I’m wondering are there any settings I need to set on the camera before connecting to SGPro?
    thanks in advance for any suggestions!

Are you using the Bulb setting in Manual mode?

Try the version found here:

We made some specific changes for the D800 that haven’t been released yet. The linked version should fix these issues.


Im pretty sure it was, because I’d set it from capture pro, but it’s worth a look. But I think when a camera is tethered it doesn’t matter what the previous program settings were? Still, that’s something to check too.

Thanks Jared! I’ll try it tonight.
Edit- tried it and it works perfectly. Thanks again! Now for some clear skies…

I tried the new version and it did not work for me.

Does this work on the USB cable for > 30s?

I have it set to single shot, manual exposure and autofocus OFF. It does connect. But hangs when I try to take a picture.

Hi Jeryyyy,
I’ve noticed a couple of little things, but now have the D800 working fine with SGPro, a G11, and a autoguider with a PHD2 interface.
First mistake I made was leaving the long exposure NR on in camera - it adds to an already ridiculous download time.
The second thing is, my laptop has usb-2 only, so it takes several minutes to get the image file. I switched to fits only mode and it seems to be a little quicker, it certainly saves disk space!
Although it looked like it was locking up, it actually got there in the end, so maybe you just need to wait a bit longer?

Thanks. Copy all you said above and will work on it. Could you explain NR?

Noise reduction. It’s a function where the camera does an internal dark subtraction. But to do this it takes a dark for the same exposure length as the light. Effectively doubling the overall exposure time.

Sgp doesn’t control this it must be set in the camera. It’s doubtful that you have it enabled.


Thanks. I downloaded a new copy, took out the cards and it crashed every time I try to take a picture. Even at 5s.

Dead in the water. Don’t get to NG. The camera just show a moving line in the window.

Can you attach the sgp logs?