No autofocus on object change even when there is a filter change

I have had persistent issues with SGPro not executing an autofocus when changing objects. This problem occurs when there is no change of filter, i.e. when the 2nd object is on the same filter or equally when there is a change of filter.
I run multiple targets on the one sequence and add new targets and delete old ones as they are finished. This means I generally use just one SGPro Sequence file.
Last night I was capturing Omega Centauri on the Red filter. There was an interruption because the shutters on my dome closed, due to dew on the rain sensor. As a result the guide star was lost and after multiple recovery attempts the sequence was aborted. All fine.
I got up about an hour after this event to check how things were going to discover the sequence had been aborted. I turned off the rain sensor and reopened the shutters. By now, the end time for the Omega Centauri sequence was passed so when I resumed the sequence, SGPro moved on to the next object which was M20, the Trifid Nebula and on the SII filter.
Now I would have expected after slewing to this object an autofocus would be started, especially because a new filter was to be used. But instead it centred on the object then tried to start the autoguider, which failed. After another recentre it got the autoguiding going and started the capture. At this point I intervened and paused the sequence. I forced an autofocus and then a recentre and got the sequence off an running again for the rest of the night.
I have put all the files pertinent to this issue in the following DropBox folder:

I included the Sequence file and the SGPro log from last night’s run. There is also a picture of the Focus Control Panel and the Autofocus Options I am using.
You will see that I have ticked “Autofocus on filter change” and “Autofocus before sequence start (not on resume)”. It is a bit unclear as to what is meant by a sequence here. Does this mean the overall sequence file, with multiple targets, or does it mean the sequence for each target. In my opinion ticking this box should mean that whenever a new target is started an autofcous will be performed. We can never assume, even if the filter remains the same, that the focus is the same in another part of the sky. Can you clarify this for me please?
I have not ticked “Autofocus on resume”. Now clearly I resumed the sequence in this instance, so this dialogue box being unticked means that no autofocus was necessarily triggered. However, surely the change of object and/or change of filter should have initiated an autofocus regardless. I obviously don’t know what would have happened had I had this dialogue box ticked…i.e. would an autofocus have been initiated. Frankly I don’t want to initiate an autofocus on every resume, as this could happen in the middle of a sequence on the same filter where there is no need for an autofocus.
I stepped through the logfile and took screen shots of the pertient bits so you can see what happened, or clearly you can refer to the logfile itself.
This issue has occurred previously, where there was no interruption, just a change to a new object. It has happened both when there is no filter change and when there is a filter change. I am at the point where I can’t rely on SGPro to execute a change of object and do the necessary autofocus before commencing on the new object. Please advise.

Does anyone have any suggestions for me on this one? I had another instance of this in the last couple of nights. I set up a new sequence with two targets, NGC 5367 and M20. I set up the sequence on NGC 5367 to finish at 12:00AM. It was running on the red filter at the time.
Now just to confuse things I got an error message saying that the focuser had been disconnected around the time of the change-over. I don’t know what bearing this had. However the sequence continued. I disconnected the focuser and then reconnected it, which worked.
However, the sequence continued. SGPro commanded TSX to slew to M20, which it did. It then did an auto centre, before restarting the autoguider…It then switched to the OIII filter with no autofocus. It started capturing the first sub…so a new object, a new filter and no autofocus performed again. I intervened at this stage, pausing the Sequence and forced the autofocus, before resuming.
I have included the log file in the DropBox folder from the first post, or this is a direct link to it:

Please advise what I need to do to get SGPro to perform an autofocus on a change of object with or without a change of filter.
Frankly I don’t understand how I can be the only one having this problem, which suggests it is something I have set up incorrectly.

Sequence Start is when you click the “Run Sequence” button and it specifically says “Run Sequence”. There are different ways to get to this state. It can be when you create a new sequence and run it (all other starts will then be a restart). Or you can clear the status of the sequence by going to Sequence>>Reset Sequence. The Sequence is the entire collection of targets.

Yes, because you’re doing a “restart” at this point and not a clean sequence start.

What you probably want is the Auto focus after automatic centering action as this will auto focus after a target change. This will probably take care of the “resume” state as well.

Jared

Thanks Jared,
It does seem that in both instances, the issue has occurred when I have paused the sequence and then resumed. In the first case, the dome shutters closed, requiring a pause and resume and in the second case the Autofocuser disconnected, again requiring a pause and resume.
Is not the fact that on resume SGPro has effectively lost its place, a bug in the software? I should be able to pause the sequence and then resume it, without SGPro forgetting to carry out the sequence correctly from that point. By that I mean that if on resume a change to a new object is required and even more importantly one with a filter change, an autofocus should be initiated regardless. This is not happening.

If I tick Auto focus after centering action, that may well force the autofocus…I don’t know yet, but that is a work around the “bug”, unless I have this incorrect, which has some negative consequences that I want to avoid. For example because I image at long focal lengths, finding a guide star can sometimes be a challenge. If it fails to find a guide star, it will recenter before restarting the guider. I clearly don’t want it also to perform an unnecessary autofocus in these circumstances.
At Sequence start a slew to the object is performed and then the autofocus takes place before the auto centering action. I presume that in these circumstances, if I’ve ticked Auto focus after centering action it won’t perform an autofocus again?
What do you think?
Niall
PS I am surprised this has not happened to anyone else, which makes me think I may be doing something wrong?